输出GPLT (20 分)
作者:互联网
给定一个长度不超过10000的、仅由英文字母构成的字符串。请将字符重新调整顺序,按GPLTGPLT....
这样的顺序输出,并忽略其它字符。当然,四种字符(不区分大小写)的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按GPLT
的顺序打印,直到所有字符都被输出。
输入格式:
输入在一行中给出一个长度不超过10000的、仅由英文字母构成的非空字符串。
输出格式:
在一行中按题目要求输出排序后的字符串。题目保证输出非空。
输入样例:
pcTclnGloRgLrtLhgljkLhGFauPewSKgt
输出样例:
GPLTGPLTGLTGLGLL
源代码
#include <iostream>
using namespace std;
int main()
{
string a,b;
getline(cin,a);
for(int i = 0;i < a.size();i ++ )
{
if(a[i]=='g'||a[i]=='G'||a[i]=='p'||a[i]=='P'||a[i]=='l'||a[i]=='L'||a[i]=='t'||a[i]=='T')b=b+a[i];
}
int x=0,y=0,z=0,v=0;
for(int i = 0;i < b.size();i ++ )
{
if(b[i]=='g'||b[i]=='G')x++;
if(b[i]=='p'||b[i]=='P')y++;
if(b[i]=='l'||b[i]=='L')z++;
if(b[i]=='t'||b[i]=='T')v++;
}
while(x+y+z+v!=0)
{
if(x!=0)
{
cout<<"G";
x--;
}
if(y!=0)
{
cout<<"P";
y--;
}
if(z!=0)
{
cout<<"L";
z--;
}
if(v!=0)
{
cout<<"T";
v--;
}
}
return 0;
}
标签:字符,20,输出,++,10000,int,字符串,GPLT 来源: https://blog.csdn.net/couchpotatoshy/article/details/123592566