【PAT】甲级 A1060 Are They Equal (25 分)
作者:互联网
If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123×10^5 with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.
Input Specification:
Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10^100 , and that its total digit number is less than 100.
Output Specification:
For each test case, print in a line YES if the two numbers are treated equal, and then the number in the standard form 0.d[1]…d[N]*10^k (d[1]>0 unless the number is 0); or NO if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.
Note: Simple chopping is assumed without rounding.
Sample Input 1:
3 12300 12358.9
Sample Output 1:
YES 0.123*10^5
Sample Input 2:
3 120 128
Sample Output 2:
NO 0.12010^3 0.12810^3
代码如下:
#include<iostream>
#include<string>
using namespace std;
int calK(int n,string s){
int a=s.find('.');
if(a>0)
s.erase(s.begin()+a,s.end());
else if(a==0)
return 0;
return s.length();
}
int main(){
int n;
string a,b;
cin>>n>>a>>b;
string::iterator it1,it2;
it1=a.begin()+n;
it2=b.begin()+n;
bool flag1=false,flag2=false;
//删掉先导0
while(a[0]=='0'){
a.erase(a.begin()+a.find('0'));
flag1=true;
}
while(b[0]=='0'){
b.erase(b.begin()+b.find('0'));
flag2=true;
}
// cout<<"s::"<<a<<" "<<b<<endl;
int m1=calK(n,a);
int m2=calK(n,b);
// cout<<"m::"<<m1<<" "<<m2<<endl;
//去掉小数点
if(a.find('.')>=0&&a.find('.')<a.length())
a.erase(a.begin()+a.find('.'));
if(b.find('.')>=0&&b.find('.')<b.length())
b.erase(b.begin()+b.find('.'));
//去掉小数点后面的先导0
if(flag1){
while(a[0]=='0'){
a.erase(a.begin()+a.find('0'));
m1--;
}
}
if(a=="") m1=0;
if(flag2){
while(b[0]=='0'){
b.erase(b.begin()+b.find('0'));
m2--;
}
}
if(b=="") m2=0;
string s1=a.substr(0,n);
string s2=b.substr(0,n);
//长度不足有效位->补零
while(s1.length()<n)
s1+='0';
while(s2.length()<n)
s2+='0';
//输出
if(s1==s2&&m1==m2){
cout<<"YES";
cout<<" 0."<<s1<<"*10^"<<m1;
}
else{
cout<<"NO";
cout<<" 0."<<s1<<"*10^"<<m1;
cout<<" 0."<<s2<<"*10^"<<m2;
}
return 0;
}
需要考虑多种情况,对我来说还是蛮有考验的。
比较典型的需要考虑的问题,如:先导0(000123和123)、全0(0000和0000.00)。再就是精度不够补0的情况。
标签:25,begin,PAT,string,int,Equal,while,erase,find 来源: https://blog.csdn.net/Hekiiu/article/details/123206021