1020 Tree Traversals (25 分)
作者:互联网
Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.
Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:
4 1 6 3 5 7 2
代码:
#include<iostream>
#include<queue>
using namespace std;
struct node
{
int data;
node* lchild,*rchild;
};
int post[35],in[35];
void levelorder(node *root)//层序遍历
{
if(root==NULL)
return;
queue<node *> Q;
Q.push(root);
while(!Q.empty())
{
node *temp=Q.front();
if(temp==root)
printf("%d",root->data);
else
printf(" %d",temp->data);
Q.pop();
if(temp->lchild)
Q.push(temp->lchild);
if(temp->rchild)
Q.push(temp->rchild);
}
}
node* creatree(int postL,int postR,int inL,int inR)//根据后序遍历和中序遍历结果,创建二叉树
{
if(postL>postR)
return NULL;
int temp=post[postR];
node* root=new node;
root->data=temp;
int k;
for(k=inL;k<=inR;k++)
if(in[k]==temp)
break;
int newk=k-inL;
root->lchild=creatree(postL,postL+newk-1,inL,inL+newk-1);
root->rchild=creatree(postL+newk,postR-1,k+1,inR);
return root;
}
int main()
{
int N;
scanf("%d",&N);
for(int i=0;i<N;i++)
scanf("%d",post+i);
for(int i=0;i<N;i++)
scanf("%d",in+i);
node *root=creatree(0,N-1,0,N-1);
levelorder(root);
return 0;
}
标签:node,25,temp,int,Traversals,Tree,postL,line,root 来源: https://blog.csdn.net/fairylyt/article/details/123136884