其他分享
首页 > 其他分享> > 1034 Head of a Gang (30 分)

1034 Head of a Gang (30 分)

作者:互联网

One way that the police finds the head of a gang is to check people’s phone calls. If there is a phone call between A and B, we say that A and B is related. The weight of a relation is defined to be the total time length of all the phone calls made between the two persons. A “Gang” is a cluster of more than 2 persons who are related to each other with total relation weight being greater than a given threshold K. In each gang, the one with maximum total weight is the head. Now given a list of phone calls, you are supposed to find the gangs and the heads.

Input Specification:
Each input file contains one test case. For each case, the first line contains two positive numbers N and K (both less than or equal to 1000), the number of phone calls and the weight threthold, respectively. Then N lines follow, each in the following format:

Name1 Name2 Time

where Name1 and Name2 are the names of people at the two ends of the call, and Time is the length of the call. A name is a string of three capital letters chosen from A-Z. A time length is a positive integer which is no more than 1000 minutes.

Output Specification:
For each test case, first print in a line the total number of gangs. Then for each gang, print in a line the name of the head and the total number of the members. It is guaranteed that the head is unique for each gang. The output must be sorted according to the alphabetical order of the names of the heads.

Sample Input 1:

8 59
AAA BBB 10
BBB AAA 20
AAA CCC 40
DDD EEE 5
EEE DDD 70
FFF GGG 30
GGG HHH 20
HHH FFF 10

Sample Output 1:

2
AAA 3
GGG 3

Sample Input 2:

8 70
AAA BBB 10
BBB AAA 20
AAA CCC 40
DDD EEE 5
EEE DDD 70
FFF GGG 30
GGG HHH 20
HHH FFF 10

Sample Output 2:

0

思路一:《算法笔记》上的思路,使用邻接矩阵以及map来实现。使用map<string, int>建立头目姓名与成员人数的关系,实现自动排序,便于输出结果。会消耗大量内存

#include <iostream>
#include <string>
#include <map>
using namespace std;

const int maxn = 2010;

map<int, string> intToString; //编号->姓名
map<string, int> stringToInt; //姓名->编号
map<string, int> Gang; // head->人数
int G[maxn][maxn], weight[maxn]; //邻接矩阵G、点权weight
int n, k, numPerson; //边数n、下限k、总人数numPerson
bool vis[maxn] = {false}; //标记是否被访问

// DFS函数访问单个连通块,nowVisit为当前访问的编号
// head为头目,numMember为成员编号,totalValue为连通块的总边权
void DFS(int nowVisit, int &head, int &numMember, int &totalValue) {
    numMember++; //成员人数加1
    vis[nowVisit] = true; //标记nowVisit已访问
    if (weight[nowVisit] > weight[head]) {
        head = nowVisit; //当前访问结点的点权大于头目的点权,则更新头目
    }
    for (int i = 0; i < numPerson; i++) { //枚举所有人
        if (G[nowVisit][i] > 0) { //如果从nowVisit能到达i
            totalValue += G[nowVisit][i]; //连通块的总边权增加该边权
            G[nowVisit][i] = G[i][nowVisit] = 0; //删除这条边,防止回头
            if (vis[i] == false) { //如果i未被访问,则递归访问i
                DFS(i, head, numMember, totalValue);
            }
        }
    }
}

// DFSTrave函数遍历整个图,获取每个连通块的信息
void DFSTrave() {
    for (int i = 0; i < numPerson; i++) { //枚举所有人
        if (vis[i] == false) { //如果i未被访问
            int head = i, numMember = 0, totalValue = 0; //头目、成员数、总边权
            DFS(i, head, numMember, totalValue); //遍历i所在的连通块
            if (numMember > 2 && totalValue > k) { //成员数大于2且总边权大于k
                // head人数为numMember
                Gang[intToString[head]] = numMember;
            }
        }
    }
}

// change函数返回姓名str对应的编号
int change(string str) {
    if (stringToInt.find(str) != stringToInt.end()) { //如果str已经出现
        return stringToInt[str]; //返回编号
    } else {
        stringToInt[str] = numPerson; // str的编号为numPerson
        intToString[numPerson] = str; // numPerson对应str
        return numPerson++; //总人数加1
    }
}

int main() {
    int w;
    string str1, str2;
    cin >> n >> k;
    for (int i = 0; i < n; i++) {
        cin >> str1 >> str2 >> w; //输入边的两个端点和点权
        int id1 = change(str1), id2 = change(str2);
        weight[id1] += w;
        weight[id2] += w;
        G[id1][id2] += w;
        G[id2][id1] += w;
    }
    DFSTrave();
    cout << Gang.size() << endl;
    for (auto it = Gang.begin(); it != Gang.end(); it++) {
        cout << it->first << " " << it->second << endl;
    }
    return 0;
}

思路二:使用邻接表来实现,同时通过使用结构体来存放头目姓名和成员人数。

#include <iostream>
#include <string>
#include <vector>
#include <unordered_map>
#include <algorithm>
using namespace std;

const int maxn = 2010;

vector<int> G[maxn]; //邻接表G
int call[maxn]; //记录每个人通话时间
bool vis[maxn]; //标记是否被访问
struct Gang { //记录每一个团伙信息
    string head;
    int num = 0, totalCall = 0; //成员数量、总共通话时间
    bool flag = false; //是否是犯罪团伙
} gang[maxn];
int n, k, numPerson = 0, callMax = 0; //边数n、下限k、总人数numPerson
unordered_map<int, string> intToString; //编号->姓名
unordered_map<string, int> stringToInt; //姓名->编号

void dfs(int u, Gang &g) {
    vis[u] = true;
    g.num++;
    g.totalCall += call[u];
    if (call[u] > callMax) {
        callMax = call[u];
        g.head = intToString[u];
    }
    for (int i = 0; i < G[u].size(); i++) {
        int v = G[u][i];
        if (vis[v] == false) {
            dfs(v, g);
        }
    }
}

bool cmp(const Gang &g1, const Gang &g2) {
    return g1.head < g2.head;
}

void init(string c) { //初始化
    if (stringToInt.count(c) == 0) { //第一次出现建立映射关系
        intToString[numPerson] = c;
        stringToInt[c] = numPerson++;
    }
}

int main() {
    int w;
    string a, b;
    cin >> n >> k;
    for (int i = 0; i < n; i++) {
        cin >> a >> b >> w;
        init(a);
        init(b);
        int ta = stringToInt[a], tb = stringToInt[b];
        call[ta] += w;
        call[tb] += w;
        G[ta].push_back(tb);
        G[ta].push_back(tb);
    }
    int numGang = 0; //记录团伙个数
    for (int i = 0; i < numPerson; i++) {
        callMax = 0; //重置最长通话时间
        if (vis[i] == false) {
            dfs(i, gang[numGang++]);
        }
    }
    sort(gang, gang + numGang, cmp); //按照头目姓名排序
    int ans = 0; //记录犯罪的团伙数
    for (int i = 0; i < numGang; i++) {
        if (gang[i].num > 2 && gang[i].totalCall / 2 > k) { //注意每条边权会被加两次
            gang[i].flag = true;
            ans++;
        }
    }
    cout << ans << endl;
    for (int i = 0; i < numGang; i++) {
        if (gang[i].flag) {
            cout << gang[i].head << " " << gang[i].num << endl;
        }
    }
    return 0;
}

标签:Head,int,30,head,numPerson,++,Gang,nowVisit,gang
来源: https://blog.csdn.net/zxc0074869/article/details/123122766