1021. Deepest Root (25)(图的遍历,dfs,连通分量的个数)
作者:互联网
A graph which is connected and acyclic can be considered a tree. The height of the tree depends on the selected root. Now you are supposed to find the root that results in a highest tree. Such a root is called the deepest root.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (<=10000) which is the number of nodes, and hence the nodes are numbered from 1 to N. Then N-1 lines follow, each describes an edge by given the two adjacent nodes' numbers.
Output Specification:
For each test case, print each of the deepest roots in a line. If such a root is not unique, print them in increasing order of their numbers. In case that the given graph is not a tree, print "Error: K components" where K is the number of connected components in the graph.
Sample Input 1:
5
1 2
1 3
1 4
2 5
Sample Output 1:
3
4
5
Sample Input 2:
5
1 3
1 4
2 5
3 4
Sample Output 2:
Error: 2 components
生词
英文 | 解释 |
---|---|
acyclic | 非循环的 |
题目大意:
给出n个结点(1~n)之间的n条边,问是否能构成一棵树,如果不能构成则输出它有的连通分量个数,如果能构成一棵树,输出能构成最深的树的高度时,树的根结点。如果有多个,按照从小到大输出。
分析:
首先深度优先搜索判断它有几个连通分量。如果有多个,那就输出Error: x components,如果只有一个,就两次深度优先搜索,先从一个结点dfs后保留最高高度拥有的结点们,然后从这些结点中的其中任意一个开始dfs得到最高高度的结点们,这两个结点集合的并集就是所求
原文链接:https://blog.csdn.net/liuchuo/article/details/52294178
题解
咱就是说,这段证明谁能看懂呢。。。(除了各位大佬
1.用set确实更方便:自动去重+自动排序!
2.并查集模板容易忘写init函数。
#include <bits/stdc++.h>
using namespace std;
const int N=100010;
vector<int> G[N];
bool isRoot[N];
int father[N];
int findFather(int x)
{
int a=x;
while(x!=father[x]){
x=father[x];
}
while(a!=father[a]){
int z=a;
a=father[a];
father[z]=x;
}
return x;
}
void Union(int a,int b)
{
int faA=findFather(a);
int faB=findFather(b);
if(faA!=faB){
father[faA]=faB;
}
}
void init(int n)
{
for(int i=1;i<=n;i++){
father[i]=i;
}
}
int calBlock(int n)
{
int Block=0;
for(int i=1;i<=n;i++){
isRoot[findFather(i)]=true;
}
for(int i=1;i<=n;i++)
Block+=isRoot[i];
return Block;
}
int maxH=0;
set<int> temp,Ans;
void DFS(int u,int Height,int pre)
{
if(Height>maxH){
temp.clear();
temp.insert(u);
maxH=Height;
}else if(Height==maxH){
temp.insert(u);
}
for(int i=0;i<G[u].size();i++){
if(G[u][i]==pre) continue;
DFS(G[u][i],Height+1,u);
}
}
int main() {
int a,b,n;
cin>>n;
init(n);
for(int i=1;i<n;i++){
cin>>a>>b;
G[a].push_back(b);
G[b].push_back(a);
Union(a,b);
}
int Block=calBlock(n);
if(Block!=1)
cout<<"Error: "<<Block<<" components"<<endl;
else{
DFS(1,1,-1);
Ans=temp;
auto it=Ans.begin();
DFS(*it,1,-1);
for(auto it=temp.begin();it!=temp.end();it++){
Ans.insert(*it);
}
for(auto it=Ans.begin();it!=Ans.end();it++)
cout<<*it<<endl;
}
return 0;
}
标签:case,25,结点,1021,temp,int,father,dfs,root 来源: https://www.cnblogs.com/moonlight1999/p/15877247.html