其他分享
首页 > 其他分享> > 1025 PAT Ranking (25 分)

1025 PAT Ranking (25 分)

作者:互联网

在这里插入图片描述
1025 PAT Ranking (25 分)
Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:
For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank
The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:
2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85
Sample Output:
9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
struct student{
	char registration_number[15];
	int score;
	int final_rank;
	int location_number;
	int local_rank;
}Student[30005];
bool cmp(student a,student b){
	if (a.score != b.score) return a.score > b.score;
	else return strcmp(a.registration_number, b.registration_number) < 0;
}
int main() {
	int N,K;
	int count = 0;
	cin >> N;
	for (int i = 1; i <= N; i++) {
		cin >> K;
		for (int j = count; j < count + K; j++) {
			cin >> Student[j].registration_number >> Student[j].score;
			Student[j].location_number = i;
		}
		sort(Student + count, Student + count + K, cmp);
		Student[count].local_rank = 1;
		for (int k = count; k < count + K; k++) {
			if (Student[k].score == Student[k - 1].score) {
				Student[k].local_rank = Student[k - 1].local_rank;
			}
			else {
				Student[k].local_rank = k-count+1;
			}
		}
		count = count + K;
	}
	cout << count << endl;
	sort(Student, Student + count, cmp);
	Student[0].final_rank = 1;
	for (int q = 1; q < count; q++) {
		if (Student[q].score == Student[q - 1].score) {
			Student[q].final_rank = Student[q - 1].final_rank;
		}
		else
		{
			Student[q].final_rank = q+1;
		}
	}
	for (int p = 0; p < count; p++) cout << Student[p].registration_number << " " << Student[p].final_rank << " " << Student[p].location_number << " " << Student[p].local_rank << endl;
}

标签:1025,Ranking,PAT,int,number,rank,score,Student,count
来源: https://blog.csdn.net/Checkmate2000/article/details/122748744