其他分享
首页 > 其他分享> > 一种括号的括号匹配

一种括号的括号匹配

作者:互联网

(我这种方法比较简陋,并未使用栈来解题)

题目描述

现在有一个括号串(由'('和')')组成的字符串。现在问你最多有多少个括号是配对的。(一个'('与一个')'算配对,无视中间是否还有是否还有其他括号)

输入

第一行输入一个T,表示T(0<T<=10)组数据。接下来T行每行输入字符串s(0<s<1000)。

输出

配对括号的个数。

样例输入

3
(()())((()
()()()(())
))))))((((((

样例输出

4
5
0
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
int main()
{
    int n;
    scanf("%d",&n);
    getchar();
    while(n)
    {
        int num;
        num=0;
        char a[1000]= {'0'};
        char b[1000]= {'0'};//储存左括号
        char c[1000]= {'0'};//用于确定该位置的括号是否被占用
        gets(a);
        int len=strlen(a);
        for(int i=0; i<len; i++)
        {
            if(a[i]=='(')
            {
                b[i]='(';//储存左括号的位置
                c[i]='0';
            }
        }
        for(int i=0; i<len; i++)
        {
            if(a[i]==')')
            {
                for(int j=i-1; j>=0; j--)//查找该右括号之前是否还有左括号
                {
                    if(b[j]=='('&&c[j]=='0')//c[j]=='0'证明该括号未被占用
                    {
                        c[j]=1;//改变数值防止二次使用
                        num++;
                        break;
                    }
                }
            }
        }
        printf("%d\n",num);
        n--;
    }
    return 0;
}

标签:匹配,int,一种,char,括号,num,include,1000
来源: https://blog.csdn.net/weixin_63298816/article/details/122704893