其他分享
首页 > 其他分享> > 1084:幂的末尾

1084:幂的末尾

作者:互联网

1084:幂的末尾


时间限制: 1000 ms         内存限制: 65536 KB
提交数: 39605     通过数: 23022

【题目描述】

幂abab的末33位数是多少?

【输入】

两个正整数a,ba,b。1≤a≤100,1≤b≤100001≤a≤100,1≤b≤10000。

【输出】

从高位到低位输出幂的末三位数字,中间无分隔符。若幂本身不足三位,在前面补零。

【输入样例】

7 2011

【输出样例】

743

#include <bits/stdc++.h>
using namespace std;
int main()
{
	int a,b,k=1;
	cin>>a>>b;
	for (int i=0;i<b;i++)
	{
		k*=a;
		k%=1000;
	}
	if(k>=100) cout<<k<<endl;
	else if(k>=10) cout<<"0"<<k<<endl;
	else cout<<"00"<<k<<endl;
	return 0;
}

标签:输出,1084,cout,int,样例,100,末尾
来源: https://blog.csdn.net/jjezpanzhipeng/article/details/122594068