其他分享
首页 > 其他分享> > 7-6 喷水装置 (25 分)

7-6 喷水装置 (25 分)

作者:互联网

1.题目描述:

长L米,宽W米的草坪里装有n个浇灌喷头。每个喷头都装在草坪中心线上(离两边各W/2米)。我们知道每个喷头的位置(离草坪中心线左端的距离),以及它能覆盖到的浇灌范围。

请问:如果要同时浇灌整块草坪,最少需要打开多少个喷头?

输入格式:

输入包含若干组测试数据。

第一行一个整数T表示数据组数。

每组数据的第一行是整数n、L和W的值,其中n≤10 000。

接下来的n行,每行包含两个整数,给出一个喷头的位置和浇灌半径。

如图1所示的示意图是样例输入的第一组数据所描述的情况。

ttt.jpg

图1

输出格式:

对每组测试数据输出一个数字,表示要浇灌整块草坪所需喷头数目的最小值。如果所有喷头都打开还不能浇灌整块草坪,则输出-1。

输入样例:

3
8 20 2
5 3
4 1
1 2
7 2
10 2
13 3
16 2
19 4
3 10 1
3 5
9 3
6 1
3 10 1
5 3
1 1
9 1

结尾无空行

输出样例:

6
2
-1

结尾无空行

数据范围与提示:

对于100%的数据,n≤15000。

2.代码展示: 

#include<bits/stdc++.h>
using namespace std;
const int MAX=15005;
struct mac{
	float left;
	float right;
}a[MAX];
bool cmp(mac x,mac y){
	return x.left<y.left;
}
int main(){
	int T;
	cin>>T;
	while(T--){
		float n,L,W;
		cin>>n>>L>>W;
		int count=0;
		for(int i=0;i<n;i++){
			float x,y;
			cin>>x>>y;
			if(y>=W/2){
				a[count].left=x-sqrt(y*y-1.0*W*W/4);
				a[count++].right=x+sqrt(y*y-1.0*W*W/4);
			}
		}
		sort(a,a+count,cmp);
		int res=0;
		float right1=0;
		int flag=1,i=0;
		while(i<count){
			if(a[i].left>right1){
				cout<<"-1"<<endl;
				flag=0;
				break;
			}
			//if(right1>=L)break;
			float max1=-1;
			while(i<count && a[i].left<=right1){
				max1=max(max1,a[i].right);
				i++;
			}
			right1=max1;
			res++;
		}
		if(flag)
		cout<<res<<endl;		
	}
	return 0;
}

题目链接:PTA | 程序设计类实验辅助教学平台

标签:count,25,装置,int,喷水,float,喷头,浇灌,草坪
来源: https://blog.csdn.net/m0_56312312/article/details/122281745