其他分享
首页 > 其他分享> > PAT Advanced 1151 LCA in a Binary Tree (30 )

PAT Advanced 1151 LCA in a Binary Tree (30 )

作者:互联网

PAT Advanced 1151 LCA in a Binary Tree (30 )

题目描述

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

Given any two nodes in a binary tree, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the binary tree, respectively. In each of the following two lines, N distinct integers are given as the inorder and preorder traversal sequences of the binary tree, respectively. It is guaranteed that the binary tree can be uniquely determined by the input sequences. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the BST, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found.

Sample Input:

6 8
7 2 3 4 6 5 1 8
5 3 7 2 6 4 8 1
2 6
8 1
7 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 6 is 3.
8 is an ancestor of 1.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

解题思路

LCA的升级版,给中序序列可以得到其BST序列,通过idx[temp] = i;,然后就是LCA的常规操作了。

Code

#include<bits/stdc++.h>
using namespace std;
unordered_map<int, int> vis, idx;
vector<int> pre;
int getLCA(int u, int v) {
	for(int i = 0; i<pre.size(); i++) {
		if(idx[pre[i]]>=idx[u] && idx[pre[i]]<=idx[v]) {
			return pre[i];
		} else if(idx[pre[i]]>=idx[v] && idx[pre[i]]<=idx[u]) {
			return pre[i]; 
		}
	}
}
int main() {
	//freopen("in.txt", "r", stdin);
	int N, M, temp, u, v;
	cin >> N >> M;
	pre.resize(M);
	for(int i = 1;i <= M; i++) {
		cin >> temp;
		idx[temp] = i;
	}
	for(int i = 0; i<M; i++) {
		cin >> pre[i];
	}
	for(int i = 0; i<N; i++) {
		cin >> u >> v;	
		if(!idx[u] && !idx[v]) {
			printf("ERROR: %d and %d are not found.\n", u, v);
		} else if(!idx[u]) {
			printf("ERROR: %d is not found.\n", u);
		} else if(!idx[v]) {
			printf("ERROR: %d is not found.\n", v);
		} else {
			int lca = getLCA(u, v);
			if(lca == u) {
				printf("%d is an ancestor of %d.\n", u, v);
			} else if(lca == v) {
				printf("%d is an ancestor of %d.\n", v, u);
			} else {
				printf("LCA of %d and %d is %d.\n", u, v, lca);
			}
		}
	}
	return 0;
}

标签:printf,Binary,PAT,idx,int,LCA,1151,ERROR,found
来源: https://blog.csdn.net/gq__97/article/details/88064502