其他分享
首页 > 其他分享> > Let the Balloon Rise

Let the Balloon Rise

作者:互联网

Problem Description

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you. 

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input
 

5 
green 
red 
blue 
red 
red 
3 
pink 
orange 
pink 
0

Sample Output

red 
pink
#include<stdio.h>
#include<string.h>
int main(){
    int n;
    char a[1000][16];
    int i,j,max=0,t=0,k;
    while(~scanf("%d",&n)){
        memset(a,0,sizeof(a));
        if(n==0){
            break;
        }
        max=0;
        k=0;
        for(i=0;i<n;i++){
            scanf("%s",&a[i]);
        }
        for(i=0;i<n;i++){
            t=0;
            for(j=i;j<n;j++){
                if(strcmp(a[i],a[j])==0){
                    t++;
                }
            }
            if(t>max){
                max=t;
                k=i;
            }
            
        }    
        printf("%s\n",a[k]);    
    }
    
    return 0;
}

 

标签:case,pink,int,Balloon,Rise,Let,test,Input,red
来源: https://blog.csdn.net/wys5wys/article/details/88044584