其他分享
首页 > 其他分享> > 穷竭搜索AOJ Exhaustive Search

穷竭搜索AOJ Exhaustive Search

作者:互联网

原题链接

Write a program which reads a sequence A of n elements and an integer M, and outputs "yes" if you can make M by adding elements in A, otherwise "no". You can use an element only once.

You are given the sequence A and q questions where each question contains Mi.

Input

In the first line n is given. In the second line, n integers are given. In the third line q is given. Then, in the fourth line, q integers (Mi) are given.

Output

For each question Mi, print yes or no.

Constraints

Sample Input 1

5
1 5 7 10 21
8
2 4 17 8 22 21 100 35

Sample Output 1

no
no
yes
yes
yes
yes
no
no

Notes

You can solve this problem by a Burte Force approach. Suppose solve(p, t) is a function which checkes whether you can make t by selecting elements after p-th element (inclusive). Then you can recursively call the following functions:

solve(0, M) solve(1, M-{sum created from elements before 1st element}) solve(2, M-{sum created from elements before 2nd element}) ...

The recursive function has two choices: you selected p-th element and not. So, you can check solve(p+1, t-A[p]) and solve(p+1, t) in solve(p, t) to check the all combinations.

For example, the following figure shows that 8 can be made by A[0] + A[2].

img

 

 

一种时间复杂度是O(2n)的究极暴力搜索算法

做法:判断每个元素是否可取,每次都有2种取法。

用递归的方式来解决(从m中加上w[i],用m是否等于M来判断是否这个数能用和来表示):

bool f;
void solve(int i,int m){ if(m == M){f = 1;return ;} if(i == n)return ; solve(i + 1,m) ; solve(i + 1,m + w[i]); return ; }

每次递归都有不选这个数(m)和选择这个数(m + w[i])两种选择,用f来标记是否可以用和来表示。

 

AC代码:

#include<bits/stdc++.h>

using namespace std;

const int N = 1e6 + 10;

int w[N];
int n,k,M;
bool f;
void solve(int i,int m){
    if(m == M){f = 1;return ;}
    if(i == n)return ;
    solve(i + 1,m) ;
    solve(i + 1,m + w[i]);
    return ;
}

int main(){
    scanf("%d",&n);
    for(int i = 0;i < n;i ++)scanf("%d",&w[i]);

    scanf("%d",&k);

    for(int i = 0;i < k;i ++){
        scanf("%d",&M);
        f = 0;
        solve(0,0);
        cout << (f?"yes" : "no") << endl;
    }

    return 0;
}

 

等学了DP再来补一个DP的做法。

标签:given,elements,return,int,穷竭,AOJ,element,solve,Exhaustive
来源: https://www.cnblogs.com/Moniq/p/15566736.html