其他分享
首页 > 其他分享> > 数据结构学习

数据结构学习

作者:互联网

数据结构学习

一、数据结构基础
PTA 1数列求和-加强版
题目:
给定某数字A(1≤A≤9)以及非负整数N(0≤N≤100000),求数列之和S=A+AA+AAA+⋯+AA⋯A(N个A)。例如A=1, N=3时,S=1+11+111=123。

输入格式:输入数字A与非负整数N。

输出格式:输出其N项数列之和S的值。

输入样例:1 3
结尾无空行
输出样例:123
结尾无空行

题解:

代码:

#include<iostream>
using namespace std;
int main()
{
    int A,N,i;
    int tempSum = 0,remainder = 0;
    long long int a[100005];
    cin>>A>>N;
    long long int t = A;
    a[0] = A;
    if(N==0)
    {
        cout<<"0";
        return 0;
    }
    for(i=0; i<N; i++)
    {
        tempSum = A*(N-i)+remainder;
        a[i] = tempSum%10;
        remainder = tempSum/10;
    }
    a[i] = remainder;
    for(i=N; i>=0; i--)
    {
        if(a[i]==0&&i==N)
        {
            continue;
        }
        cout<<a[i];
    }
    return 0;
}

标签:数列,int,long,学习,tempSum,数据结构,remainder
来源: https://blog.csdn.net/weixin_51060450/article/details/121375290