其他分享
首页 > 其他分享> > PAT 甲级 1037 Magic Coupon

PAT 甲级 1037 Magic Coupon

作者:互联网

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons NC​, followed by a line with NC​ coupon integers. Then the next line contains the number of products NP​, followed by a line with NP​ product values. Here 1≤NC​,NP​≤105, and it is guaranteed that all the numbers will not exceed 230.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:

4
1 2 4 -1
4
7 6 -2 -3

结尾无空行

Sample Output:

43

结尾无空行

题目大意

有一系列的产品,价值为整数(或正或负)。给你一系列的优惠券,优惠券的倍数为整数(或正或负),你只能拿一张优惠券购买一个产品,且该张优惠券和该个产品都不能重复使用,购买产品的价值为产品的价值×优惠券的倍数(或正或负)

给定一系列的产品和优惠券,求你能获得最大价值。

题目分析

两个数组存储products value 和coupons,然后分别取两边最大整数、次大整数相乘加到sum中去,如果遇到负数则停止。

再从反向开始遍历,分别取两边最小整数、次小整数相乘加到sum中去,如果遇到整数则停止。

AC代码

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
vector<int> coupon;
vector<int> product;
int main(){
	int N, temp;
	cin>>N;
	for (int i = 0; i < N;i++){//get coupon array
		cin>>temp;
		coupon.push_back(temp);
	}
	cin >> N;//N here  is bigger than N there
	for (int i = 0; i < N;i++){//get product array
		cin>>temp;
		product.push_back(temp);
	}

	sort(product.begin(), product.end());
	sort(coupon.begin(), coupon.end());

	int sum = 0;//amount of money you can get

	//所有正数
	int i = product.size() - 1; 
	int j = coupon.size() - 1;
	while(i>=0&&j>=0&&product[i]>0&&coupon[j]>0){
		sum += product[i--] * coupon[j--];
	}
	//所有负数
	i = 0;
	j = 0;
	while(i<product.size()&&j<coupon.size()&&product[i]<0&&coupon[j]<0){
		sum += product[i++] * coupon[j++];
	}
	cout << sum;
	return 0;
}

标签:product,优惠券,PAT,get,Coupon,back,coupon,int,Magic
来源: https://blog.csdn.net/qq_37637818/article/details/121308219