其他分享
首页 > 其他分享> > PAT 甲级 1013 Battle Over Cities

PAT 甲级 1013 Battle Over Cities

作者:互联网

题目描述

1013 Battle Over Cities (25 分)

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

题目理解

其实就是算一共把对要check的城市的相关边都去掉之后还剩多少个连通块

然后用连通块数量减2就是所需的边数(因为check的城市肯定是一个单独的连通块而且不需要连接所以减2)

因为pat数据弱所以一开始用了很蠢的方法也过了,好的办法是用并查集做

代码实现(蠢的办法)

#include <iostream>
#include <unordered_set>
using namespace std;

const int N=1010;

int p[N][N],d[N][N];
int n,m,k;
bool st[N];
unordered_set<int> s;

void dfs(int c){
    for(int i=1;i<=n;i++){
        if(p[c][i]==1&&st[i]==false){
            st[i]=1;
            s.insert(i);
            dfs(i);
        }
    }
}

int check(int c){
    s.clear();
    for(int i=1;i<=n;i++)p[c][i]=0,p[i][c]=0,st[i]= false;
    int count=-1;
    for(int i=1;i<=n;i++){
        if(i==c||st[i])continue;
        s.insert(i);
        dfs(i);
        count++;
        if(s.size()==n-1)break;
    }
    for(int i=1;i<=n;i++)p[c][i]=d[c][i],p[i][c]=d[i][c];
    return count;
}

int main(){
    cin>>n>>m>>k;
    while(m--){
        int a,b;
        cin>>a>>b;
        d[a][b]=1,d[b][a]=1;
        p[a][b]=1,p[b][a]=1;
    }
    while(k--){
        int c;
        cin>>c;
        cout<<check(c)<<endl;
    }
    return 0;
}

代码实现(并查集)

#include <iostream>
#include <cstring>

using namespace std;

const int N = 1010, M = 500010;

int n, m, k;
int p[N];

struct Edge
{
    int a, b;
}e[M];

int find(int x)
{
    if (p[x] != x) p[x] = find(p[x]);
    return p[x];
}

int main()
{
    scanf("%d%d%d", &n, &m, &k);

    for (int i = 0; i < m; i ++ ) scanf("%d%d", &e[i].a, &e[i].b);

    while (k -- )
    {
        int x;
        scanf("%d", &x);

        for (int i = 1; i <= n; i ++ ) p[i] = i;

        int cnt = n - 1;
        for (int i = 0; i < m; i ++ )
        {
            int a = e[i].a, b = e[i].b;
            if (a != x && b != x)
            {
                int pa = find(a), pb = find(b);
                if (pa != pb)
                {
                    p[pa] = pb;
                    cnt -- ;
                }
            }
        }

        printf("%d\n", cnt - 1);
    }

    return 0;
}

作者:yxc
链接:https://www.acwing.com/activity/content/code/content/316877/
来源:AcWing

标签:include,PAT,int,Over,number,highways,Battle,cities,highway
来源: https://blog.csdn.net/m0_61974219/article/details/121155779