其他分享
首页 > 其他分享> > 输出GPLT

输出GPLT

作者:互联网

给定一个长度不超过10000的、仅由英文字母构成的字符串。请将字符重新调整顺序,按GPLTGPLT....这样的顺序输出,并忽略其它字符。当然,四种字符(不区分大小写)的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按GPLT的顺序打印,直到所有字符都被输出。

输入格式:

输入在一行中给出一个长度不超过10000的、仅由英文字母构成的非空字符串。

输出格式:

在一行中按题目要求输出排序后的字符串。题目保证输出非空。

输入样例:

pcTclnGloRgLrtLhgljkLhGFauPewSKgt



结尾无空行

输出样例:

GPLTGPLTGLTGLGLL



结尾无空行

answer

#include <stdio.h>
int main(){
	int GPLT[4] = {0,0,0,0};
	char ch;
	scanf("%c",&ch);
	while(ch != '\n') {
		switch(ch) {
			case 'G':
			case 'g':
				GPLT[0] += 1;
				break;
			case 'P':
			case 'p':
				GPLT[1] += 1;
				break;
			case 'L':
			case 'l':
				GPLT[2] += 1;
				break;
			case 'T':
			case 't':
				GPLT[3] += 1;
				break;
		}
		scanf("%c",&ch);
	}
	while(1) {
		if(GPLT[0]){
			GPLT[0] -= 1;
			printf("G");
		}
		if(GPLT[1]){
			GPLT[1] -= 1;
			printf("P");
		}
		if(GPLT[2]){
			GPLT[2] -= 1;
			printf("L");
		}
		if(GPLT[3]){
			GPLT[3] -= 1;
			printf("T");
		}
		if(!GPLT[0]&&!GPLT[1]&&!GPLT[2]&&!GPLT[3])
		break;
	}
	return 0;
}

标签:case,字符,ch,输出,break,GPLT
来源: https://www.cnblogs.com/ekertree/p/15390780.html