其他分享
首页 > 其他分享> > 「ABC221」A - Seismic magnitude scales 题解

「ABC221」A - Seismic magnitude scales 题解

作者:互联网

A - Seismic magnitude scales

Time Limit: \(2\; sec\) / Memory Limit: \(1024\; MB\)

Score : \(100\; points\)

Problem Statement|题目描述

Constraints|数据范围

Input|输入

Output|输出

Sample Input 1 |样例输入 1

6 4

Sample Output 1 |样例输出 1

1024

Sample Input 2 |样例输入 2

5 5

Sample Output 2 |样例输出 2

1


分析

作为一个谨慎的人,我终究还是开了\(long\;long\),又用了快速幂。

AC代码奉上

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
inline ll power(ll a,ll b){
	if(!b)return 1;
	ll ans=1;
	while(b){
		if(b&1)ans=ans*a;
		b>>=1;
		a*=a;
	}
	return ans;
}
int main(){
	freopen("magnitude.in","r",stdin);
	freopen("magnitude.out","w",stdout);
	int a,b;
	cin>>a>>b;
	cout<<power(32,a-b);
	return 0;
} 

标签:ll,题解,energy,leq,magnitude,32,Seismic,ABC221,earthquake
来源: https://www.cnblogs.com/wintersunny/p/15366604.html