1044 火星数字 (20 分)
作者:互联网
火星人是以 13 进制计数的:
- 地球人的 0 被火星人称为 tret。
- 地球人数字 1 到 12 的火星文分别为:jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec。
- 火星人将进位以后的 12 个高位数字分别称为:tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou。
例如地球人的数字 29
翻译成火星文就是 hel mar
;而火星文 elo nov
对应地球数字 115
。为了方便交流,请你编写程序实现地球和火星数字之间的互译。
输入格式:
输入第一行给出一个正整数 N(<100),随后 N 行,每行给出一个 [0, 169) 区间内的数字 —— 或者是地球文,或者是火星文。
输出格式:
对应输入的每一行,在一行中输出翻译后的另一种语言的数字。
输入样例:
4
29
5
elo nov
tam
输出样例:
hel mar
may
115
13
#include <iostream>
#include <string>
#include <stdlib.h>
using namespace std;
string a[13] = {"tret", "jan", "feb", "mar", "apr", "may", "jun", "jly", "aug", "sep", "oct", "nov", "dec"};
string b[13] = {"...", "tam", "hel", "maa", "huh", "tou", "kes", "hei", "elo", "syy", "lok", "mer", "jou"};
int main() {
int n;
int t1, t2;
cin >> n;
getchar();
string s;
for (int i = 0; i < n; i++) {
getline(cin, s);
if (s[0] <= '9' && s[0] >= '0') {
t1 = atoi(s.c_str()) / 13;
t2 = atoi(s.c_str()) % 13;
if (t1 != 0 && t2 != 0) {
cout << b[t1] << ' '<<a[t2];
}
if (t1 == 0) {
cout << a[t2];
}
if (t1 != 0 && t2 == 0) {
cout << b[t1];
}
} else if (s.size() > 4) {
string s1, s2;
s1 = s.substr(0, 3);
s2 = s.substr(4, 3);
for (int j = 0; j < 13; j++) {
if (s1 == b[j]) {
t1 = j;
}
if (s2 == a[j]) {
t2 = j;
}
}
cout << t1 * 13 + t2;
} else {
for (int j = 0; j < 13; j++) {
if (s == a[j]) {
cout << j;
break;
}
if (s == b[j]) {
cout << j * 13;
break;
}
}
}
if (i != n - 1) {
cout << endl;
}
}
return 0;
}
标签:13,20,elo,1044,int,t2,nov,火星,string 来源: https://blog.csdn.net/weixin_53199925/article/details/120593596