其他分享
首页 > 其他分享> > A - Monthly Expense

A - Monthly Expense

作者:互联网

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called “fajomonths”. Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ’s goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input
Line 1: Two space-separated integers: N and M
Lines 2…N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day
Output
Line 1: The smallest possible monthly limit Farmer John can afford to live with.

Sample Input
7 5
100
400
300
100
500
101
400

Sample Output
500

Hint
If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.

题目大意:
给出n个数,将其分为至多m段,求和最大的一段值最少为多少,如例子
7 5
100
400
300
100
500
101
400

最优分法是{100,400}、{300,100}、{500}、{101}、{400}

和最大的集合的和为500

解题思路:
二分枚举答案,如例题,

完整代码:

#include<iostream>
using namespace std;
int main() {
	int n,n2;
	int a[100010];
	cin>>n>>n2;
	int sum=0;
	int ma=0;
	for(int i=0;i<n;i++){
		cin>>a[i];
		sum+=a[i];			//最大范围 
		ma=max(ma,a[i]);	//最小范围 
	}
	int l=ma,r=sum,m;
	while(r>l){	//二分 
		m=(l+r)/2;
		int j=1;
		sum=0;
		for(int i=0;i<n;i++){
			
			if(sum+a[i]<=m){
				sum+=a[i];
			}else{
				sum=a[i];
				j++;
			}
		}
		if(j<=n2){
			r=m;
		}else{
			l=m+1;
		}
	}
	cout<<l;
}

标签:Monthly,sum,Farmer,int,400,100,Expense,500
来源: https://blog.csdn.net/weixin_52115456/article/details/120580899