其他分享
首页 > 其他分享> > 1004 成绩排名 (20 分)

1004 成绩排名 (20 分)

作者:互联网

读入n (n>0)名学生的姓名、学号、成绩,分别输出成绩最高和成绩最低学生的姓名和学号。

输入格式:

每个测试输入包含 1 个测试用例,格式为

第 1 行:正整数 n
第 2 行:第 1 个学生的姓名 学号 成绩
第 3 行:第 2 个学生的姓名 学号 成绩
  ... ... ...
第 n+1 行:第 n 个学生的姓名 学号 成绩

其中姓名学号均为不超过 10 个字符的字符串,成绩为 0 到 100 之间的一个整数,这里保证在一组测试用例中没有两个学生的成绩是相同的。

输出格式:

对每个测试用例输出 2 行,第 1 行是成绩最高学生的姓名和学号,第 2 行是成绩最低学生的姓名和学号,字符串间有 1 空格。

输入样例:

3
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95

输出样例:

Mike CS991301
Joe Math990112
#include<stdio.h>
#include<stdlib.h> 
#include<string.h>
struct student{
	char name[20];
	char xuehao[20];
	int sid;
};

int main(){
	int n,i,t,k;
	scanf("%d",&n);
	struct student pst[n];
	char s1[20],s2[20];
	for(i=0;i<n;i++){
		scanf("%s",s1);
		strcpy(pst[i].name,s1);
		scanf("%s",s2);
		strcpy(pst[i].xuehao,s2);
		scanf("%d",&pst[i].sid);
	}
	for(i=0,k=pst[i].sid;i<n;i++){
		if(k<=pst[i].sid){
			k=pst[i].sid;
			t=i;
		}
	}
	printf("%s %s\n",pst[t].name,pst[t].xuehao);
	
	for(i=0,k=pst[i].sid;i<n;i++){
		if(k>=pst[i].sid){
			k=pst[i].sid;
			t=i;
		}
	}
	printf("%s %s",pst[t].name,pst[t].xuehao);
	return 0;
}

标签:成绩排名,1004,20,学号,姓名,sid,成绩,pst
来源: https://blog.csdn.net/useless_man/article/details/120155747