其他分享
首页 > 其他分享> > 1025 PAT Ranking (25 分)

1025 PAT Ranking (25 分)

作者:互联网

1025 PAT Ranking (25 分)

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

代码

1.地区排名的输入在我们去输完当个地区的学生信息之后就可以开始判断了。我之前写的那个是所有数据全部输入,然后主按地区排名,次级按成绩排,在遍历列表排排名顺序。然后就超时了·_·

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct testee{
	char registration_number[15];
	int score;
	int fina_rank;
	int location_number;
	int local_rank;
}T[30010];

bool cmp(testee a, testee b){ 
	if(a.score != b.score) return a.score > b.score;//先按成绩排 ,成绩高的在前面 
	else return strcmp(a.registration_number,b.registration_number) < 0;//同一成绩按照区号排,区号小的在前面 
}

int main(){
	int n,k;
	scanf("%d",&n);
	int len = 0;
	for(int i = 0; i < n; i++){
		scanf("%d",&k);
		for(int j = 0; j < k; j++){
			scanf("%s %d", &T[len].registration_number,&T[len].score);
			T[len].location_number = i + 1;
			len++;
		}
		sort(T+len - k, T + len,cmp);
		T[len - k].local_rank = 1;//将该考场的第一名的local_rank记为1
		for(int j = len - k + 1; j < len; j++){
				if(T[j].score == T[j - 1].score) T[j].local_rank = T[j - 1].local_rank;
				else T[j].local_rank = j + 1 - (len - k);//local_rank为该考生前的人数
		} 
	}
	printf("%d\n",len);
	sort(T,T+len,cmp);
	int r = 1;
	for(int i = 0; i < len; i++){
		if(T[i].score != T[i - 1].score) r = i + 1;
		printf("%s ", T[i].registration_number);
		printf("%d %d %d\n",r,T[i].location_number,T[i].local_rank);
	}
	return 0;
} 

标签:1025,Ranking,PAT,int,number,rank,score,len,local
来源: https://www.cnblogs.com/shiff/p/15111417.html