其他分享
首页 > 其他分享> > HDU - 1495 非常可乐(搜索)

HDU - 1495 非常可乐(搜索)

作者:互联网

非常可乐

原题链接

Problem Description

   大家一定觉的运动以后喝可乐是一件很惬意的事情,但是seeyou却不这么认为。因为每次当seeyou买了可乐以后,阿牛就要求和seeyou一起分享这一瓶可乐,而且一定要喝的和seeyou一样多。但seeyou的手中只有两个杯子,它们的容量分别是N 毫升和M 毫升 可乐的体积为S (S<101)毫升 (正好装满一瓶) ,它们三个之间可以相互倒可乐 (都是没有刻度的,且 S==N+M,101>S>0,N>0,M>0) 。聪明的ACMER你们说他们能平分吗?如果能请输出倒可乐的最少的次数,如果不能输出"NO"。

Input

三个整数 : S 可乐的体积 , N 和 M是两个杯子的容量,以"0 0 0"结束。

Output

如果能平分的话请输出最少要倒的次数,否则输出"NO"。

Sample Input

7 4 3
4 1 3
0 0 0

Sample Output

NO
3

广搜模拟每一种情况。暴力求解。

#include<iostream>
#include<queue>
#include<cstring>
using namespace std;

int book[103][103][103];
int h[3];

struct ss
{
	int s[3],t;
};

ss now,nex;
queue<ss>p;

void pour(int a,int b)
{
	int k=nex.s[a]+nex.s[b];
	if(k>=h[b])
	nex.s[b]=h[b];
	else
	nex.s[b]=k;
	nex.s[a]=k-nex.s[b];
}

int bfs()
{
	ss now1;
	now1.s[0]=h[0],now1.s[1]=0,now1.s[2]=0,now1.t=0;
	p.push(now1);
	while(!p.empty())
	{
		now=p.front();
		p.pop();
		if((now.s[0]==now.s[1]&&now.s[0]==h[0]/2)||(now.s[1]==now.s[2]&&now.s[1]==h[0]/2)||(now.s[2]==now.s[0]&&now.s[0]==h[0]/2))
		{
			return now.t;
		}
		for(int i=0;i<3;i++)
		for(int j=0;j<3;j++)
		{
			if(i==j)
			continue;
			nex=now;
			pour(i,j);
			if(!book[nex.s[0]][nex.s[1]][nex.s[2]])
			{
				nex.t++;
				book[nex.s[0]][nex.s[1]][nex.s[2]]=1;
				p.push(nex);
				
			}
		}
	}
	return -1;
}
int main()
{
	while(cin>>h[0]>>h[1]>>h[2]&&h[0])
	{
		while(!p.empty())
		p.pop();
		memset(book,0,sizeof(book));
		book[h[0]][0][0]=1;
		if(h[0]%2)
		{
			cout<<"NO"<<endl;
			continue;
		}
		int k=bfs();
		if(k!=-1)
		cout<<k<<endl;
		else
		cout<<"NO"<<endl;
	}
	
}

标签:seeyou,HDU,int,1495,nex,now,now1,可乐
来源: https://blog.csdn.net/m0_56863442/article/details/119081092