其他分享
首页 > 其他分享> > 3.16 成绩大排队

3.16 成绩大排队

作者:互联网

【问题描述】

读入n名学生的姓名、学号、成绩,分别输出成绩最高和成绩最低学生的姓名和学号。

【输入形式】

每个测试输入包含1个测试用例,格式为

 第1行:正整数n
  第2行:第1个学生的姓名 学号 成绩
  第3行:第2个学生的姓名 学号 成绩
  ... ... ...
  第n+1行:第n个学生的姓名 学号 成绩
其中姓名和学号均为不超过20个字符的字符串,成绩为0到100之间的一个整数,这里保证在一组测试用例中没有两个学生的成绩是相同的。

【输出形式】

对每个测试用例输出2行,第1行是成绩最高学生的姓名和学号,第2行是成绩最低学生的姓名和学号,字符串间有1空格。

【样例输入】

3
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95

【样例输出】

Mike CS991301
Joe Math990112

#include <iostream>
#include <algorithm>
using namespace std;
struct Student{
	string name;
	string id;
	int score;
};
bool cmp(const Student& left,const Student& right)
{
	if(left.score!=right.score)
	return left.score>right.score;
	return true;
}
int main(){
	int n;
	cin>>n;
	Student stu[n];
	for(int i=0;i<n;i++)
	cin>>stu[i].name>>stu[i].id>>stu[i].score;
	sort(stu,stu+n,cmp); 
	cout<<stu[0].name<<" "<<stu[0].id<<endl;
	cout<<stu[n-1].name<<" "<<stu[n-1].id<<endl;
}

标签:学号,int,排队,3.16,stu,score,姓名,成绩
来源: https://blog.csdn.net/qq_52170360/article/details/118788557