其他分享
首页 > 其他分享> > 1008 Elevator (20 分)

1008 Elevator (20 分)

作者:互联网

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 5 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N N N, followed by N N N positive numbers. All the numbers in the input are less than 100 100 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

3 2 3 1

Sample Output:

41

中文题意

坐电梯,每上一层花6s,下一层花4s,每个楼层需要停留5s。现给出n个楼层,初始在0层,求按顺序经过这n个楼层所花费的总时间。

思路

遍历整个数组,记录之前的楼层,拿现在的楼层减去之前的楼层。判断是上升,还是下降,对应地再加上电梯运行时间和停留时间。

AC代码

#include<bits/stdc++.h>
using namespace std;

int main(){
	int n,now,pre=0,sum=0;
	cin>>n;
	for(int i=1;i<=n;i++){
		cin>>now;
		if(now-pre>0){
			sum+=(now-pre)*6;
		}
		else{
			sum+=(pre-now)*4;
		}
		sum+=5;
		pre=now;
	}
	cout<<sum<<endl;
	return 0;
}

标签:pre,20,sum,elevator,楼层,Elevator,1008,now,numbers
来源: https://blog.csdn.net/zhaofangfang_/article/details/118634538