其他分享
首页 > 其他分享> > [PAT乙级]1017 A除以B

[PAT乙级]1017 A除以B

作者:互联网

本题要求计算 A/B,其中 A 是不超过 1000 位的正整数,B 是 1 位正整数。你需要输出商数 Q 和余数 R,使得 A=B×Q+R 成立。
输入格式:

输入在一行中依次给出 A 和 B,中间以 1 空格分隔。
输出格式:

在一行中依次输出 Q 和 R,中间以 1 空格分隔。
输入样例:

123456789050987654321 7

输出样例:

17636684150141093474 3

代码如下:

#include <iostream>
#include <string>
using namespace std;

int main()
{
	int B = 0;
	string str;
	cin >> str;
	cin >> B;
	int Q = 0;
	int R = 0;
	bool isFirst = true;
	for (int i = 0; i < str.length(); i++)
	{
		int Q = (R * 10 + (str[i] - '0')) / B;
		if (isFirst&& str.length() > 1)
		{
			if (Q != 0 )
			{
				cout << Q;
			}
			isFirst = false;
		}
		else cout << Q;

		R = (R * 10 + (str[i] - '0')) % B;
	}
	cout << " " << R << endl;
	return 0;
}

标签:输出,include,PAT,isFirst,int,样例,乙级,str,1017
来源: https://blog.csdn.net/m0_51955470/article/details/117812658