其他分享
首页 > 其他分享> > 1016_Phone_Bills

1016_Phone_Bills

作者:互联网


title: 1016_Phone_Bills
math: false
date: 2021-06-06 19:44:16
categories: PTA
tags: 模拟


A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (≤1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (MM:dd:HH:mm), and the word on-line or off-line.

For each test case, all dates will be within a single month. Each on-line record is paired with the chronologically next record for the same customer provided it is an off-line record. Any on-line records that are not paired with an off-line record are ignored, as are off-line records not paired with an on-line record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers’ names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:HH:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:

10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line

Sample Output:

CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

代码实现:

先把输入样例按名称排序,名称一样的按时间排序,只收纳满足要求的数据(前后名称相等且前面状态为on-line,后面状态为off-line),然后对每对有效的数据进行计算。

注意:不可以用差值的方法计算,这样无法解决跨天且第二天小时数小于第一天小时数的问题(也可以解决,但是比较麻烦)。直接计算00:00:00到此刻的时间,然后取差值即可。

#include<iostream>
#include <map>
#include <vector>
#include <algorithm>

using namespace std;

int rate[25] = {0};//最后一位记录一整天的花费,有的情况下可能会跨天

class node {
public:
    string name;
    int month, day, hour, minute, status, time;
};

bool cmp(node a, node b) {
    return a.name == b.name ? a.time < b.time : a.name < b.name;
}

//double Cost(node &a, node &b) {
//    double cost;
//    double hourCost = 0;
//    for (int i = a.hour + 1; i < b.hour; ++i) {
//        hourCost += rate[i] * 60;
//    }
//    cost = (b.day - a.day) * 60 * rate[24] + (60 - a.minute) * rate[a.hour] + b.minute * rate[b.hour] + hourCost;
//    return cost / 100.0;
//}
//这个只能过第一个样例,如果遇到跨天且第二天的小时数小于第一天的小时数则不能得到正确答案
//如01:12:00到02:02:00

double billFromZero(node &a, node &b) {
    double totala = rate[a.hour] * a.minute + rate[24] * 60 * a.day;
    for (int i = 0; i < a.hour; i++)
        totala += rate[i] * 60;

    double totalb = rate[b.hour] * b.minute + rate[24] * 60 * b.day;
    for (int i = 0; i < b.hour; i++)
        totalb += rate[i] * 60;

    return (totalb - totala) / 100.0;
}

int main() {
    for (int i = 0; i < 24; ++i) {
        cin >> rate[i];
        rate[24] += rate[i];
    }
    int n;
    cin >> n;
    vector<node> data(n);
    for (int i = 0; i < n; ++i) {
        cin >> data[i].name;
        scanf("%d:%d:%d:%d", &data[i].month, &data[i].day, &data[i].hour, &data[i].minute);
        string temp;
        cin >> temp;
        data[i].status = (temp == "on-line") ? 1 : 0;
        data[i].time = data[i].day * 24 * 60 + data[i].hour * 60 + data[i].minute;
    }
    //录入结束
    sort(data.begin(), data.end(), cmp);
    map<string, vector<node>> custom;
    for (int i = 1; i < n; ++i) {
        if (data[i].name == data[i - 1].name && data[i - 1].status == 1 && data[i].status == 0) {//满足成对的要求
            custom[data[i].name].push_back(data[i - 1]);
            custom[data[i].name].push_back(data[i]);
        }
    }//此时每个人对应的vector中每相邻两个刚好成对


    for (auto it:custom) {//开始计算每个人的账单并输出
        vector<node> man = it.second;
        cout << it.first;
        printf(" %02d\n", man[0].month);
        double Total = 0.0;
        for (int i = 0; i < man.size(); i += 2) {
//            double cost = Cost(man[i], man[i + 1]);
            double cost = billFromZero(man[i], man[i + 1]);

            int costTime = man[i + 1].time - man[i].time;
            printf("%02d:%02d:%02d %02d:%02d:%02d %d $%.2f\n", man[i].day, man[i].hour, man[i].minute, man[i + 1].day,
                   man[i + 1].hour, man[i + 1].minute, costTime, cost);
            Total += cost;
        }
        printf("Total amount: $%.2f\n", Total);
    }

    return 0;
}

标签:00,01,hour,Phone,rate,1016,Bills,data,line
来源: https://blog.csdn.net/qq_42322831/article/details/117635653