编程语言
首页 > 编程语言> > C++9018:1157/POJ1088——滑雪

C++9018:1157/POJ1088——滑雪

作者:互联网

题目来自:http://218.5.5.242:9018/JudgeOnline/problem.php?id=1157

题目来自:http://poj.org/problem?id=1088

题目描述

        trs喜欢滑雪。他来到了一个滑雪场,这个滑雪场是一个矩形,为了简便,我们用r行c列的矩阵来表示每块地形。为了得到更快的速度,滑行的路线必须向下倾斜。         例如样例中的那个矩形,可以从某个点滑向上下左右四个相邻的点之一。例如24-17-16-1,其实25-24-23…3-2-1更长,事实上这是最长的一条。

输入

输入文件 第1行:  两个数字r,c(1< =r,c< =100),表示矩阵的行列。 第2..r+1行:每行c个数,表示这个矩阵。

输出

输出文件 仅一行:  输出1个整数,表示可以滑行的最大长度。

样例输入

5 5
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9

样例输出

25
作者分析:这道题是经典的记忆化搜索的题目,也是DAG动态规划,用d数组表示当前格子最长的路线,dp函数递归查找。
#include <iostream>
#include <cstring>
using namespace std;

int n,m,a[101][101],d[101][101],answer = -1;
int dp(int x,int y){
    if (x > n || x < 1 || y > m || y < 1) return 0;
    int ans = d[x][y];
    if (d[x][y] == 0){
        int maxn = 0;
        if (a[x + 1][y] < a[x][y]) maxn = max(maxn,dp(x + 1,y));
        if (a[x - 1][y] < a[x][y]) maxn = max(maxn,dp(x - 1,y));
        if (a[x][y + 1] < a[x][y]) maxn = max(maxn,dp(x,y + 1));
        if (a[x][y - 1] < a[x][y]) maxn = max(maxn,dp(x,y - 1));
        maxn += 1;
        d[x][y] = maxn;
        ans = maxn;
    }
    return ans;
}
int main(){
    cin >> n >> m;
    memset(d,0,sizeof(d));
    for (int i = 1;i <= n;i++){
        for (int j = 1;j <= m;j++){
            cin >> a[i][j];
        }
    }
    for (int i = 1;i <= n;i++){
        for (int j = 1;j <= m;j++){
            answer = max(answer,dp(i,j));
        }
    }
    cout << answer;
    return 0;
}

标签:25,int,max,1157,POJ1088,maxn,101,9018,dp
来源: https://www.cnblogs.com/linyiweiblog/p/14697491.html