编程语言
首页 > 编程语言> > 【PAT甲级A1126】 Eulerian Path (25分)(c++)

【PAT甲级A1126】 Eulerian Path (25分)(c++)

作者:互联网

1126 Eulerian Path (25分)

作者:CHEN, Yue
单位:浙江大学
代码长度限制:16 KB
时间限制:300 ms
内存限制:64 MB

In graph theory, an Eulerian path is a path in a graph which visits every edge exactly once. Similarly, an Eulerian circuit is an Eulerian path which starts and ends on the same vertex. They were first discussed by Leonhard Euler while solving the famous Seven Bridges of Konigsberg problem in 1736. It has been proven that connected graphs with all vertices of even degree have an Eulerian circuit, and such graphs are called Eulerian. If there are exactly two vertices of odd degree, all Eulerian paths start at one of them and end at the other. A graph that has an Eulerian path but not an Eulerian circuit is called semi-Eulerian. (Cited from https://en.wikipedia.org/wiki/Eulerian_path)

Given an undirected graph, you are supposed to tell if it is Eulerian, semi-Eulerian, or non-Eulerian.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 2 numbers N (≤ 500), and M, which are the total number of vertices, and the number of edges, respectively. Then M lines follow, each describes an edge by giving the two ends of the edge (the vertices are numbered from 1 to N).

Output Specification:
For each test case, first print in a line the degrees of the vertices in ascending order of their indices. Then in the next line print your conclusion about the graph – either Eulerian, Semi-Eulerian, or Non-Eulerian. Note that all the numbers in the first line must be separated by exactly 1 space, and there must be no extra space at the beginning or the end of the line.

Sample Input 1:

7 12
5 7
1 2
1 3
2 3
2 4
3 4
5 2
7 6
6 3
4 5
6 4
5 6

Sample Output 1:

2 4 4 4 4 4 2
Eulerian

Sample Input 2:

6 10
1 2
1 3
2 3
2 4
3 4
5 2
6 3
4 5
6 4
5 6

Sample Output 2:

2 4 4 4 3 3
Semi-Eulerian

Sample Input 3:

5 8
1 2
2 5
5 4
4 1
1 3
3 2
3 4
5 3

Sample Output 3:

3 3 4 3 3
Non-Eulerian

题意:

给出连通图,计算每个结点的度,当所有度为偶数时则为Eulerian,当仅有两个奇数时则为Semi-Eulerian,其余为Non-Eulerian

思路:

用邻接链表来统计每个结点的度,因为还要用深度优先来检查能不能连通。结点的度就是邻接链表的大小,统计计数个数。

参考代码:

#include <iostream>
#include <vector>

using namespace std;
int n, m, a, b, cnt = 0;
vector<vector<int>> v;
bool flag = false, vis[501] = {false};

void dfs(int st) {
    vis[st] = true;
    if (st == n) {
        flag = true;
        return;
    }
    for (int i = 0; i < v[st].size(); i++)
        if (!vis[v[st][i]])dfs(v[st][i]);
}

int main() {
    scanf("%d%d", &n, &m);
    v.resize(n + 1);
    for (int i = 0; i < m; i++) {
        scanf("%d%d", &a, &b);
        v[a].push_back(b);
        v[b].push_back(a);
    }
    for (int i = 1; i <= n; i++) {
        if (i != 1)printf(" ");
        printf("%d", v[i].size());
        if (v[i].size() % 2 == 1)cnt++;
    }
    dfs(1);
    if (flag && cnt == 0)printf("\nEulerian");
    else if (flag && cnt == 2)printf("\nSemi-Eulerian");
    else printf("\nNon-Eulerian");
    return 0;
}

如有错误,欢迎指正

标签:25,PAT,A1126,int,graph,st,Sample,path,Eulerian
来源: https://blog.csdn.net/qq_37112826/article/details/110294255