编程语言
首页 > 编程语言> > PAT甲级真题 1043 Is It a Binary Search Tree (25分) C++实现(二叉搜索树,递归前序转后序)

PAT甲级真题 1043 Is It a Binary Search Tree (25分) C++实现(二叉搜索树,递归前序转后序)

作者:互联网

题目

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line “YES” if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or “NO” if not. Then if the answer is “YES”, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:
7
8 6 5 7 10 8 11
Sample Output 1:
YES
5 7 6 8 11 10 8
Sample Input 2:
7
8 10 11 8 6 7 5
Sample Output 2:
YES
11 8 10 7 5 6 8
Sample Input 3:
7
8 6 8 5 10 9 11
Sample Output 3:
NO

思路

这道题很难理解。

题目意思应该是,给了一个序列,问是否是某个二叉搜索树的前序或镜像前序序列?

即可转化为,假设它是某个树的前序序列,其能否构造成二叉搜索树?

假设它是前序序列,假设它能构成二叉搜索树,看是否有矛盾。

二叉搜索树的性质是,左子树上的所有节点均小于根,右子树上的所有节点均大于等于根;

前序序列是:根 左子树 右子树,即第一个元素是根,接着有连续一段小于根的值构成左子树,再接着有连续一段大于等于根的值构成右子树。(镜像树同理)

例子

比如测试用例1:

7
8 6 5 7 10 8 11

可成功划分为:
在这里插入图片描述
接着继续划分左右子树,均符合要求。

再看测试用例3:

7
8 6 8 5 10 9 11

以第一个元素8为根,小于它的元素时6、5,大于等于它的元素是8、10、9、11,第一次划分就失败了。
在这里插入图片描述

具体方法

  1. 检查是否是二叉搜索树,按照根 左子树 右子树的方式迭代划分序列,若发现不符合要求的,返回false;若一直符合要求,则输出YES,输出其后序遍历数列。
  2. 再检查是否是镜像二叉搜索树,按照根 右子树 左子树的方式迭代划分序列,若发现不符合要求的,直接输出“No”;若一直符合要求,则输出YES,输出其后序遍历数列。

这里学习了柳神的方法:

  1. 检查序列的同时,将后序序列保存到post数组
  2. 若符合要求则递归检查其左子树和右子树,最后把根节点加入post数组;若不符合要求直接返回。
  3. 最后检查post数组元素个数是否等于n,即可知是否符合要求。

代码

#include <iostream>
#include <vector>
using namespace std;

void getPost(vector<int> pre, int l, int r, vector<int> &post, bool isMirror){
    if (l==r){
        post.push_back(pre[l]);
    }
    else if(l < r){
        int i = l + 1; 
        int j = r;
        if (!isMirror){
            while(i<=r && pre[i]<pre[l]) i++;
            while(j>l && pre[j]>=pre[l]) j--;
        }
        else{
            while(i<=r && pre[i]>=pre[l]) i++;
            while(j>l && pre[j]<pre[l]) j--;
        }
        if (j < i){
            getPost(pre, l+1, j, post, isMirror);
            getPost(pre, i, r, post, isMirror);
            post.push_back(pre[l]);
        }
    }
    return;
}

int main(){
    int n;
    cin >> n;
    vector<int> pre(n);
    for(int i = 0; i < n; i++){
        cin >> pre[i];
    }
    vector<int> post;
    getPost(pre, 0, n-1, post, false);
    if (post.size()<n){  //若假设是二叉搜索树不成立
        post.clear();
        getPost(pre, 0, n-1, post, true);
    }
    if(post.size()<n){  //若假设是镜像二叉搜索树仍不成立
        cout << "NO" << endl;
    }
    else{
        cout << "YES" << endl;
        cout << post[0];
        for (int i=1; i<n; i++){
            cout << " " << post[i];
        }
    }
    return 0;
}
zhang35 发布了180 篇原创文章 · 获赞 14 · 访问量 8402 私信 关注

标签:1043,Binary,pre,10,前序,符合要求,二叉,11,post
来源: https://blog.csdn.net/zhang35/article/details/104532911