数据结构(六)散列查找 —— 编程作业02 :Hashing
作者:互联网
题目描述: 这个问题的任务很简单,在哈希表中插入一系列截然不同的正整数,并输出输入数字的位置。哈希函数被定义为H(key)=key%TSize,其中TSize是哈希表的最大尺寸。平方探测(仅正增量)用于解决冲突。
请注意,表的大小最好是素数。如果用户给出的最大尺寸不是素数,必须将表的尺寸重新定义为比用户给出的尺寸大的最小素数。
输入格式: 每个输入文件包含一个测试用例。
对于每种情况,第一行包含两个正数:MSize (≤10
4
^4
4)和N (≤MSize ),它们分别是用户定义的表大小和输入数字的数量。
然后在下一行给出N个不同的正整数。
一行中的所有数字都用空格隔开。
输出规格: 对于每个测试用例,在一行中打印输入数字的相应位置(索引从0开始)。
一行中的所有数字都用空格隔开,行尾一定不能有多余的空格。
如果无法插入号码,请打印“-”。
输入样例:
4 4
10 6 4 15
输出样例:
0 1 4 -
代码实现:
#include<iostream>
using namespace std;
#define MAXTABLESIZE 100000
#define NOTFIND -1
typedef int ElementType;
typedef enum { // 单元格状态,分别对应:有合法元素和有空位
Legitimate, Empty
} EntryType;
typedef struct HashEntry Cell;
struct HashEntry { // 单元格
ElementType data; // 存值
EntryType info; // 存状态
};
typedef struct HashTbl *HashTable;
struct HashTbl { // 哈希表
int TableSize; // 大小
Cell *Cells; // 数组
};
// 除留余数法哈希函数
int Hash(int key, int p)
{
return key % p;
}
// 查找下一个素数
int NextPrime(int N)
{
int p = N % 2 ? N : N + 1;
int i;
if (N <= 2)
return 2;
else if (N <= 3)
return 3;
while (p <= MAXTABLESIZE)
{
for (i = (int)sqrt(p); i > 2; i--)
if (!(p%i)) // 不是素数
break;
if (i == 2) // 找到了
break;
p += 2;
}
return p;
}
// 创建哈希表
HashTable CreateTable(int TableSize)
{
HashTable H;
H = (HashTable)malloc(sizeof(struct HashTbl));
H->TableSize = NextPrime(TableSize);
H->Cells = (Cell *)malloc(sizeof(struct HashEntry)*H->TableSize);
for (int i = 0; i < H->TableSize; i++)
H->Cells[i].info = Empty;
return H;
}
//查找
int Find(HashTable H, ElementType key)
{
int NewPos, CurrentPos;
int CNum = 0; // 记录冲突次数
CurrentPos = NewPos = Hash(key, H->TableSize);
// 如果当前状态不为空,且一直不等,一直做
while (H->Cells[NewPos].info != Empty && H->Cells[NewPos].data != key)
{
CNum++;
NewPos = (CurrentPos + CNum * CNum) % H->TableSize;
if (CNum == H->TableSize / 2) // 没找到
return NOTFIND;
}
return NewPos;
}
int Insert(HashTable H, ElementType key)
{
int pos;
pos = Find(H, key);
if (pos == NOTFIND) // 如果没找到
return NOTFIND;
else if (H->Cells[pos].info != Legitimate)
{
H->Cells[pos].info = Legitimate;
H->Cells[pos].data = key;
}
return pos;
}
int main()
{
HashTable H;
int M, N;
int key;
cin >> M >> N;
H = CreateTable(M);
for (int i = 0; i < N; i++)
{
cin >> key;
int pos = Insert(H, key);
if (i)
cout << " ";
if (pos == NOTFIND)
cout << "-";
else
cout << pos;
}
cout << endl;
system("pause");
return 0;
}
测试: 输入样例的测试效果如下图所示。
标签:02,return,TableSize,int,Cells,pos,key,散列,Hashing 来源: https://blog.csdn.net/HUAI_BI_TONG/article/details/117729674