今年暑假不AC
作者:互联网
题目: 今年暑假不AC
“今年暑假不AC?”
“是的。”
“那你干什么呢?”
“看世界杯呀,笨蛋!”
“@#$%^&*%…”
确实如此,世界杯来了,球迷的节日也来了,估计很多ACMer也会抛开电脑,奔向电视了。
作为球迷,一定想看尽量多的完整的比赛,当然,作为新时代的好青年,你一定还会看一些其它的节目,比如新闻联播(永远不要忘记关心国家大事)、非常6+7、超级女生,以及王小丫的《开心辞典》等等,假设你已经知道了所有你喜欢看的电视节目的转播时间表,你会合理安排吗?(目标是能看尽量多的完整节目)
Input
输入数据包含多个测试实例,每个测试实例的第一行只有一个整数n(n<=100),表示你喜欢看的节目的总数,然后是n行数据,每行包括两个数据Ti_s,Ti_e (1<=i<=n),分别表示第i个节目的开始和结束时间,为了简化问题,每个时间都用一个正整数表示。n=0表示输入结束,不做处理。
Output
对于每个测试实例,输出能完整看到的电视节目的个数,每个测试实例的输出占一行。
Sample Input
12
1 3
3 4
0 7
3 8
15 19
15 20
10 15
8 18
6 12
5 10
4 14
2 9
0
Sample Output
5
题解:
定义结构体存储每一个节目的开始和结束的时间,首先,按照每一个节目的结束时间进行排序,然后根据贪心原则进行判断,如果前一个节目的结束时间小于等于后一个节目的开始时间,这num加一。
代码:
#include<bits/stdc++.h>
using namespace std;
struct node {
int start;
int end;
};
int n;
vector<node>mv;
void init() {
for (int i = 0; i < n; i++) {
int x, y;
cin >> x >> y;
node p;
p.start = x;
p.end = y;
mv.push_back(p);
}
}
bool check(node p,node q) {
if (p.end < q.end) {
return true;
}
else if(p.end==q.end) {
if (p.start <= q.start) {
return true;
}
else {
return false;
}
}
else {
return false;
}
}
int solve() {
sort(mv.begin(), mv.end(), check);
//cout << mv[0].start << ' ' << mv[0].end << endl;
int num = 1;
int i = 0, j = 1;
while (j<n) {
if (mv[i].end<=mv[j].start) {
//cout << mv[j].start << ' ' << mv[j].end << endl;
num++;
i = j;
j++;
}
else {
j++;
}
}
return num;
}
int main() {
while (true) {
cin >> n;
if (n == 0) {
break;
}
init();
cout << solve() << endl;
mv.clear();
}
return 0;
}
标签:node,AC,end,start,今年,节目,int,实例,暑假 来源: https://blog.csdn.net/weixin_45775741/article/details/113004662