其他分享
首页 > 其他分享> > 1007 Maximum Subsequence Sum (25分) PAT 甲级

1007 Maximum Subsequence Sum (25分) PAT 甲级

作者:互联网

1007 Maximum Subsequence Sum (25分)

Given a sequence of K integers { N1, N2, …, N**K }. A continuous subsequence is defined to be { N**i, N**i+1, …, N**j } where 1≤ijK. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

~

浙大数据结构mooc遇到过这种题,在线算法。

如果遇到测试点4 5的问题,注意边界情况。(详情看代码前几行)

代码

// 注意 边界情况
// 一种全是负数 输出 first和last
// 一种有一个 0
// 区分一个0 和全是负数 就将maxSum设置为负数 可以区分他们

#include <iostream>
using namespace std;
int main()
{
    int N;
    cin >> N;
    int left = 0, right = 0, tmpleft = 0;
    bool nextBeTmpLeft = true;
    int maxSum = -1;
    int thisSum = 0;
    int first, last;
    for (int i = 0; i < N; ++i)
    {

        int cur;
        cin >> cur;
        if (i == 0)
            first = cur;
        else if (i == N - 1)
            last = cur;
        thisSum += cur;
        if (nextBeTmpLeft)
        {
            tmpleft = cur;
            nextBeTmpLeft = false;
        }
        if (thisSum > maxSum)
        {
            maxSum = thisSum;
            right = cur;
            left = tmpleft;
        }
        if (thisSum <= 0)
        {
            thisSum = 0;
            nextBeTmpLeft = true;
        }
    }
    if (maxSum >= 0)
        printf("%d %d %d", maxSum, left, right);
    else
        printf("%d %d %d", 0, first, last);
}

标签:25,PAT,cur,int,Sum,last,thisSum,maxSum,first
来源: https://blog.csdn.net/Chantec/article/details/112834422