其他分享
首页 > 其他分享> > HDoj 2029 Palindromes _easy version

HDoj 2029 Palindromes _easy version

作者:互联网

Problem Description “回文串”是一个正读和反读都一样的字符串,比如“level”或者“noon”等等就是回文串。请写一个程序判断读入的字符串是否是“回文”。  

 

Input 输入包含多个测试实例,输入数据的第一行是一个正整数n,表示测试实例的个数,后面紧跟着是n个字符串。  

 

Output 如果一个字符串是回文串,则输出"yes",否则输出"no".  

 

Sample Input 4 level abcde noon haha  

 

Sample Output yes no yes no  

 

Author lcy  

 

Source C语言程序设计练习(五)  

 

Recommend lcy   |   We have carefully selected several similar problems for you:  2031 2030 2032 2033 2035    C语言代码如下:
#include<stdio.h>
#include<string.h>
int main()
{
    int n=0;
    char s[100];
    int flag;
    scanf("%d",&n);
    for(int i=0;i<n;i++)
    {
        flag=1;
        scanf("%s",s);
        for(int i=0;i<(int)strlen(s)/2;i++)
            if(s[i]!=s[strlen(s)-i-1])
            {
                flag=0;
                break;
            }
        if(flag==0)
            printf("no\n");
        else
            printf("yes\n");
    }
}

 

标签:Palindromes,no,int,version,字符串,Input,yes,2029,回文
来源: https://www.cnblogs.com/wzmm/p/12586822.html