其他分享
首页 > 其他分享> > ACM入门-ZOJ 1383 Binary Numbers 二进制数

ACM入门-ZOJ 1383 Binary Numbers 二进制数

作者:互联网

题目来自ZOJ 1383 链接

题目

Given a positive integer n, print out the positions of all 1’s in its binary representation. The position of the least significant bit is 0.
Example
The positions of 1’s in the binary representation of 13 are 0, 2, 3.
Task
Write a program which for each data set:reads a positive integer n,computes the positions of 1’s in the binary representation of n,writes the result.
Input
The first line of the input contains exactly one positive integer d equal to the number of data sets, 1 <= d <= 10. The data sets follow.
Each data set consists of exactly one line containing exactly one integer n, 1 <= n <= 10^6.
Output
The output should consists of exactly d lines, one line for each data set.
Line i, 1 <= i <= d, should contain increasing sequence of integers separated by single spaces - the positions of 1’s in the binary representation of the i-th input number.
Sample Input
1
13
Sample Output
0 2 3

分析

代码

#include <iostream>
using namespace std;

int main()
{
    int d;
    cin >> d;
    int num;
    int pos = 0;
    for (int i = 0; i < d; i++)
    {
        pos = 0;
        cin >> num;
        while (num!=0)
        {
            if (num % 2 == 1)
            {
                cout << pos;
                if (num / 2 != 0)cout << " ";
            }
            num = num / 2;
            pos++;
        }
        cout << endl;
    }
    return 0;
}

标签:Binary,int,positions,ZOJ,exactly,ACM,num,integer,data
来源: https://blog.csdn.net/inkforest/article/details/104826163