ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

487-3279(有问题)

2020-03-02 09:55:32  阅读:393  来源: 互联网

标签:10 int number telephone 问题 num newNum 487 3279


Businesses like to have memorable telephone numbers. One way to make a telephone number memorable is to have it spell a memorable word or phrase. For example, you can call the University of Waterloo by dialing the memorable TUT-GLOP. Sometimes only part of the number is used to spell a word. When you get back to your hotel tonight you can order a pizza from Gino's by dialing 310-GINO. Another way to make a telephone number memorable is to group the digits in a memorable way. You could order your pizza from Pizza Hut by calling their ``three tens'' number 3-10-10-10.

The standard form of a telephone number is seven decimal digits with a hyphen between the third and fourth digits (e.g. 888-1200). The keypad of a phone supplies the mapping of letters to numbers, as follows:

A, B, and C map to 2
D, E, and F map to 3
G, H, and I map to 4
J, K, and L map to 5
M, N, and O map to 6
P, R, and S map to 7
T, U, and V map to 8
W, X, and Y map to 9

There is no mapping for Q or Z. Hyphens are not dialed, and can be added and removed as necessary. The standard form of TUT-GLOP is 888-4567, the standard form of 310-GINO is 310-4466, and the standard form of 3-10-10-10 is 310-1010.

Two telephone numbers are equivalent if they have the same standard form. (They dial the same number.)

Your company is compiling a directory of telephone numbers from local businesses. As part of the quality control process you want to check that no two (or more) businesses in the directory have the same telephone number.

Input

The input will consist of one case. The first line of the input specifies the number of telephone numbers in the directory (up to 100,000) as a positive integer alone on the line. The remaining lines list the telephone numbers in the directory, with each number alone on a line. Each telephone number consists of a string composed of decimal digits, uppercase letters (excluding Q and Z) and hyphens. Exactly seven of the characters in the string will be digits or letters.

Output

Generate a line of output for each telephone number that appears more than once in any form. The line should give the telephone number in standard form, followed by a space, followed by the number of times the telephone number appears in the directory. Arrange the output lines by telephone number in ascending lexicographical order. If there are no duplicates in the input print the line:

No duplicates.

Sample Input

12
4873279
ITS-EASY
888-4567
3-10-10-10
888-GLOP
TUT-GLOP
967-11-11
310-GINO
F101010
888-1200
-4-8-7-3-2-7-9-
487-3279

Sample Output

310-1010 2
487-3279 4
888-4567 3

题解:
#define _CRT_SECURE_NO_WARNINGS
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
 int n;
 cin >> n;
 char(*num)[100] = new char[n][100];
 int *newNum = new int[n];
 for (int i = 0; i < n; i++) {
  cin >> num[i];
 }  for (int i = 0; i < n; i++) {
  newNum[i] = 0;
  for (int j = 0; j < strlen(num[i]); j++) {
   if (num[i][j] != '-') {
    if (num[i][j] >= 48 && num[i][j] <= 57) {
     newNum[i] = newNum[i] * 10 + num[i][j] - 48;
    }else {
     if (num[i][j] == 'A' || num[i][j] == 'B' || num[i][j] == 'C') {
      newNum[i] = newNum[i] * 10 + 2;
      continue;
     }
     if (num[i][j] == 'D' || num[i][j] == 'E' || num[i][j] == 'F') {
      newNum[i] = newNum[i] * 10 + 3;
      continue;
     }
     if (num[i][j] == 'G' || num[i][j] == 'H' || num[i][j] == 'I') {
      newNum[i] = newNum[i] * 10 + 4;
      continue;
     }
     if (num[i][j] == 'J' || num[i][j] == 'K' || num[i][j] == 'L') {
      newNum[i] = newNum[i] * 10 + 5;
      continue;
     }
     if (num[i][j] == 'M' || num[i][j] == 'N' || num[i][j] == 'O') {
      newNum[i] = newNum[i] * 10 + 6;
      continue;
     }
     if (num[i][j] == 'P' || num[i][j] == 'R' || num[i][j] == 'S') {
      newNum[i] = newNum[i] * 10 + 7;
      continue;
     }
     if (num[i][j] == 'T' || num[i][j] == 'U' || num[i][j] == 'V') {
      newNum[i] = newNum[i] * 10 + 8;
      continue;
     }
     if (num[i][j] == 'W' || num[i][j] == 'X' || num[i][j] == 'Y') {
      newNum[i] = newNum[i] * 10 + 9;
     }
    }
    
   }
  }
 }
 sort(newNum, newNum + n);
 /*for (int i = 0; i < n; i++) {
  cout << newNum[i] << endl;
 }*/
 int ret ;
 struct duplicates
 {
  int num;
  int c;
 }du;
 int no = 0;
 for (int i = 0; i < n-1; i++) {
  ret = 1;
  while (newNum[i] == newNum[i + 1]) {
   if (i + 1 == n) {
    break;
   }
   ret++;
   i++;
  }
  if (ret > 1) {
   du.num = newNum[i];
   du.c = ret;
   no = 1;
   cout << du.num / 10000 << "-" << du.num % 10000 << " " << du.c << endl;
  }
  i++;
 }
 if (no == 0) {
  cout << "No duplicates." << endl;
 }
 return 0;
}

标签:10,int,number,telephone,问题,num,newNum,487,3279
来源: https://www.cnblogs.com/lijiahui-123/p/12393959.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有