OJ基础练习三 问题 B: 大大的求和
作者:互联网
OJ基础练习三
问题 B: 大大的求和
时间限制: 1 Sec 内存限制: 32 MB
提交: 8 解决: 7
[状态] [提交] [命题人:外部导入]
题目描述
小明在做小红给他出的算术题加法题,但是小红为了治一治小明懒惰的毛病,给他出的数都很大,这下小明郁闷了,想请你帮忙。
输入
输入的第一行是一个正整数N,表示一共有N组测试数据。
每组数据由1~100行正整数组成,每行正整数的长度不大于100位。
当输入0时,表示此组数据输入完毕。
输出
对于每组输入数据,输出所有数字的总和。每两组输出数据之间有一个空行。
样例输入 Copy
2
123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0
12
34
0
样例输出 Copy
370370367037037036703703703670
46
运行错误50
#include<bits/stdc++.h>
#include<string>
#include<stack>
using namespace std;
string ab(string a,string b){
string res="";
if(a=="0"){
return b;
}
stack<char> st;
int la=a.length()-1;
int lb=b.length()-1;
int c=0;
while(la>=0 && lb>=0){
c+=a.at(la)-'0'+b.at(la)-'0';
st.push((char)(c%10+'0'));
c/=10;
--la;
--lb;
}
while(c!=0){
st.push((char)(c%10+'0'));
c/=10;
}
if(la>0){
res=a.substr(0,la);
}
else if(lb>0){
res=b.substr(0,lb);
}
while(!st.empty()){
res+=st.top();
st.pop();
}
return res;
}
int main()
{
int t;
scanf("%d",&t);
while(t--){
string s="0";
string temp;
while(cin>>temp){
if(temp=="0"){
cout<<s<<endl;
break;
}
s=ab(s,temp);
}
if(t>0){
printf("\n");
}
}
return 0;
}
答案错误50
//#include<bits/stdc++.h>
#include<string>
#include<stack>
#include<iostream>
#include<stdio.h>
using namespace std;
string ab(string a,string b){
string res="";
if(a=="0"){
return b;
}
stack<char> st;
int la=a.length()-1;
int lb=b.length()-1;
int c=0;
while(la>=0 && lb>=0){
int at=a.at(la)-'0';
int bt=b.at(lb)-'0';
c+=at+bt;
st.push((char)(c%10+'0'));
c/=10;
--la;
--lb;
}
while(c!=0){
st.push((char)(c%10+'0'));
c/=10;
}
if(la>0){
res=a.substr(0,la);
}
else if(lb>0){
res=b.substr(0,lb);
}
while(!st.empty()){
res+=st.top();
st.pop();
}
return res;
}
int main()
{
int t;
scanf("%d",&t);
while(t--){
string s="0";
string temp;
while(cin>>temp){
if(temp=="0"){
cout<<s<<endl;
break;
}
s=ab(s,temp);
}
if(t>0){
printf("\n");
}
}
return 0;
}
正确100
//#include<bits/stdc++.h>
#include<string>
#include<stack>
#include<iostream>
#include<stdio.h>
using namespace std;
string ab(string a,string b){
string res="";
if(a=="0"){
return b;
}
stack<char> st;
int la=a.length()-1;
int lb=b.length()-1;
int c=0;
while(la>=0 && lb>=0){
int at=a.at(la)-'0';
int bt=b.at(lb)-'0';
c+=at+bt;
st.push((char)(c%10+'0'));
c/=10;
--la;
--lb;
}
while(la>=0){
int at=a.at(la)-'0';
c+=at;
st.push((char)(c%10+'0'));
c/=10;
--la;
}
while(lb>=0){
int bt=a.at(lb)-'0';
c+=bt;
st.push((char)(c%10+'0'));
c/=10;
--lb;
}
while(c!=0){
st.push((char)(c%10+'0'));
c/=10;
}
while(!st.empty()){
res+=st.top();
st.pop();
}
return res;
}
int main()
{
int t;
scanf("%d",&t);
while(t--){
string s="0";
string temp;
while(cin>>temp){
if(temp=="0"){
if(s!="0"){
cout<<s<<endl;
}
break;
}
s=ab(s,temp);
// cout<<s<<endl;
}
if(t>0){
printf("\n");
}
}
return 0;
}
RY_zeze
发布了17 篇原创文章 · 获赞 0 · 访问量 85
私信
关注
标签:lb,OJ,la,求和,while,st,大大的,int,string 来源: https://blog.csdn.net/weixin_43640962/article/details/104171740