其他分享
首页 > 其他分享> > 天梯赛真题 树的遍历(递归)

天梯赛真题 树的遍历(递归)

作者:互联网

此题纪念一下一点都不擅长递归的我,非要用递归的方法来做,靠自己的力量,经过两个小时最终成功的励志故事!

 

题意:

给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数N(≤30),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

输出样例:

4 1 6 3 5 7 2

ac代码:

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<algorithm>
#include<string>
#include<cmath>
#include<cstring>
using namespace std;
int a[35],b[35];
int ans[100000];
int mx;
void f(int l,int r,int R,int x)
{
    ans[x]=a[R];
    mx=max(mx,x);
    if(l==r)
        return;
    int i;
    for(i=l;i<=r;i++)
        if(b[i]==a[R])
            break;
    if(l<=i-1)
        f(l,i-1,R-r+i-1,x*2);
    if(i+1<=r)
        f(i+1,r,R-1,x*2+1);
}
int main()
{
    int n,i;
    cin>>n;
    for(i=1;i<=n;i++)
        cin>>a[i];
    for(i=1;i<=n;i++)
        cin>>b[i];
    f(1,n,n,1);
    cout<<ans[1];
    for(i=2;i<=mx;i++)
        if(ans[i]!=0)
            cout<<" "<<ans[i];
    return 0;
}

 

涂涂817 发布了11 篇原创文章 · 获赞 0 · 访问量 323 私信 关注

标签:遍历,递归,int,赛真题,天梯,序列,include,mx
来源: https://blog.csdn.net/weixin_43790882/article/details/104147798