其他分享
首页 > 其他分享> > PTA(Advanced Level)1046.Shortest Distance

PTA(Advanced Level)1046.Shortest Distance

作者:互联网

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3,105]), followed by N integer distances D1 D2 ⋯ DN, where Di is the distance between the i-th and the (i+1)-st exits, and *D**N* is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:
5 1 2 4 14 9
3
1 3
2 5
4 1
Sample Output:
3
10
7
思路
代码
#include<bits/stdc++.h>
using namespace std;
int a[100010] = {0};
int length[100010] = {0};
int main()
{
    int n;
    scanf("%d", &n);
    int sum = 0;
    for(int i=1;i<=n;i++)
    {
        scanf("%d", &a[i]);
        sum += a[i];
        length[i] = sum;
    }
    int m;
    scanf("%d", &m);
    int l, r;
    int t; //暂时存储距离
    while(m--)
    {
        scanf("%d %d", &l, &r);
        if(l > r)   swap(l, r);
        t = length[r-1] - length[l-1];
        printf("%d\n", min(t, sum - t));
    }
    return 0;
}
引用

https://pintia.cn/problem-sets/994805342720868352/problems/994805435700199424

标签:Distance,contains,1046,exits,Level,int,between,each,distance
来源: https://www.cnblogs.com/MartinLwx/p/11650217.html