洛谷 P1120 小木棍 [数据加强版]
作者:互联网
洛谷 P1120 小木棍 [数据加强版]
Description
乔治有一些同样长的小木棍,他把这些木棍随意砍成几段,直到每段的长都不超过50
现在,他想把小木棍拼接成原来的样子,但是却忘记了自己开始时有多少根木棍和它们的长度。
给出每段小木棍的长度,编程帮他找出原始木棍的最小可能长度。
Input
共二行。
第一行为一个单独的整数N表示砍过以后的小木棍的总数,其中N≤65
(管理员注:要把超过50的长度自觉过滤掉,坑了很多人了!)
第二行为N个用空个隔开的正整数,表示N根小木棍的长度。
Output
- 一个数,表示要求的原始木棍的最小可能长度
Sample Input
9 5 2 1 5 2 1 5 2 1
Sample Output
6
题解:
- 搜索。
- 这题蓝书lyd老师讲得太好了,蒟蒻自愧不如。
- 但是lyd老师的讲解里有图,我就不搬运了。
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#define N 105
using namespace std;
int n, t, sum, val, len, cnt;
int a[N];
bool vis[N];
bool dfs(int tot, int cab, int pos)
{
if(tot > cnt) return 1;
if(cab == len) return dfs(tot + 1, 0, 1);
int tag = 0;
for(int i = pos; i <= n; i++)
if(!vis[i] && cab + a[i] <= len && tag != a[i])
{
vis[i] = 1;
if(dfs(tot, cab + a[i], i + 1)) return 1;
tag = a[i];
vis[i] = 0;
if(!cab || cab + a[i] == len) return 0;
}
return 0;
}
int main()
{
cin >> n;
for(int i = 1; i <= n; i++)
{
cin >> a[++t];
if(a[t] > 50) t--;
else sum += a[t], val = max(val, a[t]);
}
n = t;
sort(a + 1, a + 1 + n);
reverse(a + 1, a + 1 + n);
for(len = val; len <= sum; len++)
if(sum % len == 0)
{
cnt = sum / len;
if(dfs(1, 0, 1)) break;
memset(vis, 0, sizeof(vis));
}
cout << len;
return 0;
}
标签:洛谷,加强版,val,int,长度,len,木棍,P1120,include 来源: https://www.cnblogs.com/BigYellowDog/p/11525161.html