标签:25 total mooncakes thousand 1070 tons Mooncake line include
1070 Mooncake (25 分)
Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival. Many types of fillings and crusts can be found in traditional mooncakes according to the region's culture. Now given the inventory amounts and the prices of all kinds of the mooncakes, together with the maximum total demand of the market, you are supposed to tell the maximum profit that can be made.
Note: partial inventory storage can be taken. The sample shows the following situation: given three kinds of mooncakes with inventory amounts being 180, 150, and 100 thousand tons, and the prices being 7.5, 7.2, and 4.5 billion yuans. If the market demand can be at most 200 thousand tons, the best we can do is to sell 150 thousand tons of the second kind of mooncake, and 50 thousand tons of the third kind. Hence the total profit is 7.2 + 4.5/2 = 9.45 (billion yuans).
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers N (≤1000), the number of different kinds of mooncakes, and D(≤500 thousand tons), the maximum total demand of the market. Then the second line gives the positive inventory amounts (in thousand tons), and the third line gives the positive prices (in billion yuans) of N kinds of mooncakes. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print the maximum profit (in billion yuans) in one line, accurate up to 2 decimal places.
Sample Input:
3 200
180 150 100
7.5 7.2 4.5
Sample Output:
9.45
#include <iostream>
#include <cstdio>
#include <set>
#include <string>
#include <string.h>
#include <math.h>
#include <algorithm>
#include <list>
#include <queue>
#include <stack>
#include <vector>
using namespace std;
struct node{
double total;
double price;
double per;
};
bool cmp(node &a,node &b){
return a.per > b.per;
}
int main(){
ios::sync_with_stdio(false);
int n,m;
cin>>n>>m;
node node1[n];
for(int i=0;i<n;i++){
cin>>node1[i].total;
}
for(int i=0;i<n;i++){
cin>>node1[i].price;
}
for(int i=0;i<n;i++){
node1[i].per = node1[i].price * 1.0 / node1[i].total;
}
sort(node1,node1+n,cmp);
double sum = 0.0;
for(int i=0;i<n;i++){
if(m < node1[i].total){
sum += m * node1[i].per;
break;
}
else{
sum += node1[i].price;
m -= node1[i].total;
}
}
printf("%.2lf\n",sum);
return 0;
}
标签:25,total,mooncakes,thousand,1070,tons,Mooncake,line,include
来源: https://blog.csdn.net/qq_41700374/article/details/100560895
本站声明:
1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。