叶子的染色(树型dp)
作者:互联网
给一棵m个结点的无根树,你可以选择一个度数大于1的结点作为根,然后给一些结点(根、内部结点和叶子均可)着以黑色或白色。你的着色方案应该保证根结点到每个叶子的简单路径上都至少包含一个有色结点(哪怕是这个叶子本身)。 对于每个叶结点u,定义c[u]为从根结点从U的简单路径上最后一个有色结点的颜色。给出每个c[u]的值,设计着色方案,使得着色结点的个数尽量少。
Input
第一行包含两个正整数m, n,其中n是叶子的个数,m是结点总数。结点编号为1,2,…,m,其中编号1,2,… ,n是叶子。以下n行每行一个0或1的整数(0表示黑色,1表示白色),依次为c[1],c[2],…,c[n]。以下m-1行每行两个整数a,b(1<=a < b <= m),表示结点a和b 有边相连。
Output
仅一个数,即着色结点数的最小值。
Sample Input
5 3
0
1
0
1 4
2 5
4 5
3 5
Sample Output
2
Hint
M<=10000
N<=5021
题意:给一棵m个结点的根树,你可以选择一个度数大于1的结点作为根,然后给一些结点(根、内部结点和叶子均可)着以黑色或白色。你的着色方案应该保证根结点到每个叶子的简单路径上都至少包含一个有色结点(哪怕是这个叶子本身)。 对于每个叶结点u,定义c[u]为从根结点从U的简单路径上最后一个有色结点的颜色。给出每个c[u]的值,设计着色方案,使得着色结点的个数尽量少。
转移方程:dp[root][0]+=min(dp[e[i].to][0]-1,dp[e[i].to][1]);
dp[root][1]+=min(dp[e[i].to][1]-1,dp[e[i].to][0]);
代码:
#include<algorithm>
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
const int INF=0x3f3f3f3f;
const int maxn=10005;
int m,n,c[maxn],head[maxn],cnt,dp[maxn][2];
struct Edge{
int to,next;
}e[maxn*2];
void add_edge(int u,int v){
e[cnt].to=v;
e[cnt].next=head[u];
head[u]=cnt++;
}
void dfs(int root,int fa){
dp[root][0]=dp[root][1]=1;
if(root<=n){
if(c[root]==0)
dp[root][1]=INF;
else
dp[root][0]=INF;
}
for(int i=head[root];i!=-1;i=e[i].next)
if(e[i].to!=fa){
dfs(e[i].to,root);
dp[root][0]+=min(dp[e[i].to][0]-1,dp[e[i].to][1]);
dp[root][1]+=min(dp[e[i].to][1]-1,dp[e[i].to][0]);
}
}
int main(){
memset(head,-1,sizeof(head));
cin>>m>>n;
cnt=0;
for(int i=1;i<=n;i++) cin>>c[i];
for(int i=1;i<m;i++){
int x,y;
cin>>x>>y;
add_edge(x,y);
add_edge(y,x);
}
dfs(n+1,-1);
cout<<min(dp[n+1][0],dp[n+1][1]);
return 0;
}
标签:叶子,结点,int,染色,着色,树型,root,dp 来源: https://blog.csdn.net/qq_44238714/article/details/99717825