其他分享
首页 > 其他分享> > 洛谷 P2073 送花

洛谷 P2073 送花

作者:互联网

洛谷 P2073 送花

Description

Input

Output

Sample Input

1 1 1
1 2 5
2
1 3 3
3
1 5 2
-1

Sample Output

8 5

Data Size

题解:

#include <iostream>
#include <cstdio>
#include <cstdlib>
#define N 100005
#define inf 0x7fffffff
using namespace std;

struct T {int l, r, v1, v2, dat;} t[N];
int op, root, tot, ans1, ans2;

int read()
{
    int x = 0; char c = getchar();
    while(c < '0' || c > '9') c = getchar();
    while(c >= '0' && c <= '9') {x = x * 10 + c - '0'; c = getchar();}
    return x;
}

int New(int v1, int v2)
{
    t[++tot].v1 = v1, t[tot].v2 = v2;
    t[tot].dat = rand();
    return tot;
}

void zig(int &y)
{
    int x = t[y].l;
    t[y].l = t[x].r, t[x].r = y, y = x;
}

void zag(int &x)
{
    int y = t[x].r;
    t[x].r = t[y].l, t[y].l = x, x = y;
}

void insert(int &p, int v1, int v2)
{
    if(!p) {p = New(v1, v2); return;}
    if(v1 == t[p].v1) return;
    if(v1 < t[p].v1)
    {
        insert(t[p].l, v1, v2);
        if(t[t[p].l].dat > t[p].dat) zig(p);
    }
    else
    {
        insert(t[p].r, v1, v2);
        if(t[t[p].r].dat > t[p].dat) zag(p);
    }
}

bool find(int p, int val)
{
    if(!p) return 0;
    if(t[p].v1 == val) return 1;
    if(val < t[p].v1) return find(t[p].l, val);
    else return find(t[p].r, val);
}

int preNext(int op, int val)
{
    int ans = op == 0 ? 2 : 1, p = root;
    while(p)
    {
        if(t[p].v1 == val)
        {
            if(!op && t[p].l)
            {
                p = t[p].l;
                while(t[p].r) p = t[p].r;
                ans = p; break;
            }
            else if(!op) break;
            if(op && t[p].r)
            {
                p = t[p].r;
                while(t[p].l) p = t[p].l;
                ans = p; break;
            }
            else if(op) break;
        }
        if(!op && t[p].v1 < val && t[p].v1 > t[ans].v1) ans = p;
        if(op && t[p].v1 > val && t[p].v1 < t[ans].v1) ans = p;
        p = val < t[p].v1 ? t[p].l : t[p].r;
    }
    return t[ans].v1;
}

void erase(int &p, int val)
{
    if(!p) return;
    if(val == t[p].v1)
    {
        if(t[p].l || t[p].r)
        {
            if(!t[p].r || t[t[p].l].dat > t[t[p].r].dat) zig(p), erase(t[p].r, val);
            else zag(p), erase(t[p].l, val);
        }
        else p = 0;
        return;
    }
    val < t[p].v1 ? erase(t[p].l, val) : erase(t[p].r, val);
}

void dfs(int p)
{
    if(!p) return;
    if(t[p].v1 != inf && t[p].v1 != -inf) ans1 += t[p].v1;
    if(t[p].v2 != inf && t[p].v2 != -inf) ans2 += t[p].v2;
    dfs(t[p].l), dfs(t[p].r);
}

int main()
{
    New(inf, inf), New(-inf, -inf), root = 1, t[1].l = 2;
    while(scanf("%d", &op) == 1)
    {
        if(op == -1) break;
        if(op == 1)
        {
            int bea = read(), cos = read();
            if(!find(root, cos)) insert(root, cos, bea);
        }
        else if(op == 2)
        {
            int cos = preNext(0, inf);
            if(cos != -inf) erase(root, cos);
        }
        else if(op == 3)
        {
            int cos = preNext(1, -inf);
            if(cos != inf) erase(root, cos);
        }
    }
    dfs(root);
    cout << ans2 << ' ' << ans1 << endl;
    return 0;
}

标签:洛谷,val,int,P2073,花束,送花,v1,inf,op
来源: https://www.cnblogs.com/BigYellowDog/p/11324369.html