1122:计算鞍点
作者:互联网
1122:计算鞍点
时间限制: 1000 ms 内存限制: 65536 KB
【题目描述】
给定一个5*5的矩阵,每行只有一个最大值,每列只有一个最小值,寻找这个矩阵的鞍点。鞍点指的是矩阵中的一个元素,它是所在行的最大值,并且是所在列的最小值。
例如:在下面的例子中(第4行第1列的元素就是鞍点,值为8 )。
11 3 5 6 9
12 4 7 8 10
10 5 6 9 11
8 6 4 7 2
15 10 11 20 25
【输入】
输入包含一个5行5列的矩阵。
【输出】
如果存在鞍点,输出鞍点所在的行、列及其值,如果不存在,输出"not found"。
【输入样例】
11 3 5 6 9
12 4 7 8 10
10 5 6 9 11
8 6 4 7 2
15 10 11 20 25
【输出样例】
4 1 8
【代码】
#include<iostream>
using namespace std;
int main()
{
int a[7][7];
int i;
int j;
int h;
int max;
int flagmax;
int temp=0;//Used to determine whether a saddle point is found
for(i=1;i<=5;i++)
for(j=1;j<=5;j++)
cin>>a[i][j];
for(i=1;i<=5;i++)
{
// initialization
max=a[i][1];
flagmax=1;
// find the maximum value for each row
for(j=1;j<=5;j++)
{
if(a[i][j]>max)
{
max=a[i][j];
flagmax=j;
}
}
//Then determine if this column is the minimum
for(h=1;h<=5;h++)
{
if(a[h][flagmax]<a[i][flagmax])
break;
}
if(h==6)//If h is equal to 6, it is the minimum value of the column
{
cout<<i<<" "<<flagmax<<" "<<a[i][flagmax];
temp=1;
}
}
if(temp==0)
cout<<"not found";
return 0;
}
标签:11,10,输出,int,1122,矩阵,计算,鞍点 来源: https://blog.csdn.net/Obey_bey_an/article/details/98231404