1082 射击比赛
作者:互联网
问题描述:
本题目给出的射击比赛的规则非常简单,谁打的弹洞距离靶心最近,谁就是冠军;谁差得最远,谁就是菜鸟。本题给出一系列弹洞的平面坐标(x,y),请你编写程序找出冠军和菜鸟。我们假设靶心在原点(0,0)。
输入格式:输入在第一行中给出一个正整数 N(≤ 10 000)。随后 N 行,每行按下列格式给出:ID x y
其中 ID 是运动员的编号(由 4 位数字组成);x 和 y 是其打出的弹洞的平面坐标(x,y),均为整数,且 0 ≤ |x|, |y| ≤ 100。题目保证每个运动员的编号不重复,且每人只打 1 枪。
输出格式:输出冠军和菜鸟的编号,中间空 1 格。题目保证他们是唯一的。输入样例:
3
0001 5 7
1020 -1 3
0233 0 -1
输出样例:
0233 0001
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
struct ss {
int h;
double d;
bool operator<(const struct ss&a)const {
return d<a.d;
}
};
int main() {
//简单的水题,考结构体
int n;
scanf("%d",&n);
struct ss a[n];
for(int i=0; i<n; ++i) {
int x,y;
scanf("%d%d%d",&a[i].h,&x,&y);
a[i].d=sqrt(x*x+y*y);
}
sort(a,a+n);
printf("%04d %04d\n",a[0].h,a[n-1].h);
return 0;
}
标签:平面坐标,1082,菜鸟,给出,射击,弹洞,格式,include,比赛 来源: https://blog.csdn.net/qq_40991687/article/details/90742068