其他分享
首页 > 其他分享> > 1064 朋友数——20分

1064 朋友数——20分

作者:互联网

如果两个整数各位数字的和是一样的,则被称为是“朋友数”,而那个公共的和就是它们的“朋友证号”。例如123和51就是朋友数,因为1+2+3 = 5+1 = 6,而6就是它们的朋友证号。给定一些整数,要求你统计一下它们中有多少个不同的朋友证号。注意:我们默认一个整数自己是自己的朋友。

输入格式:

输入第一行给出正整数N。随后一行给出N个正整数,数字间以空格分隔。题目保证所有数字小于104。

输出格式:

首先第一行输出给定数字中不同的朋友证号的个数;随后一行按递增顺序输出这些朋友证号,数字间隔一个空格,且行末不得有多余空格。

输入样例:

8
123 899 51 998 27 33 36 12

输出样例:

4
3 6 9 26

| 代码长度限制 | 时间限制 | 内存限制 |
| 16KB |400ms | 64MB |

代码:

#include<bits/stdtr1c++.h>
using namespace std;
int main() {
	int n;
	cin >> n;
	set<int> st;
	string s;
	for (int i = 0; i < n; i++) {
		int sum = 0;
		cin >> s;
		for (auto x : s) sum += (x - '0'); //求每个数的各位数字之和
		st.emplace(sum); //将结果存入集合中
	}
	cout << int(st.size()) << endl;
	for (auto it = st.begin(); it != st.end(); it++) {
		if (it == st.begin()) printf("%d", *it);
		else printf(" %d", *it);
	}
	return 0;
}

标签:20,数字,朋友,sum,1064,空格,int,证号
来源: https://www.cnblogs.com/Fare-well/p/16584891.html