L1-3 阅览室
作者:互联网
天梯图书阅览室请你编写一个简单的图书借阅统计程序。当读者借书时,管理员输入书号并按下S键,程序开始计时;当读者还书时,管理员输入书号并按下E键,程序结束计时。书号为不超过1000的正整数。当管理员将0作为书号输入时,表示一天工作结束,你的程序应输出当天的读者借书次数和平均阅读时间。
注意:由于线路偶尔会有故障,可能出现不完整的纪录,即只有S没有E,或者只有E没有S的纪录,系统应能自动忽略这种无效纪录。另外,题目保证书号是书的唯一标识,同一本书在任何时间区间内只可能被一位读者借阅。
输入格式:
输入在第一行给出一个正整数N(≤10),随后给出N天的纪录。每天的纪录由若干次借阅操作组成,每次操作占一行,格式为:
书号([1, 1000]内的整数) 键值(S或E) 发生时间(hh:mm,其中hh是[0,23]内的整数,mm是[0, 59]内整数)
每一天的纪录保证按时间递增的顺序给出。
输出格式:
对每天的纪录,在一行中输出当天的读者借书次数和平均阅读时间(以分钟为单位的精确到个位的整数时间)。
输入样例:
3
1 S 08:10
2 S 08:35
1 E 10:00
2 E 13:16
0 S 17:00
0 S 17:00
3 E 08:10
1 S 08:20
2 S 09:00
1 E 09:20
0 E 17:00
输出样例:
2 196
0 0
1 60
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <iomanip>
#include <algorithm>
#include <map>
#include <set>
#include <queue>
#include <vector>
#define inf 0x3f3f3f3f
using namespace std;
typedef long long ll;
int st[1001];
int main(){
int n,m,a,b,cnt=0,res1=0;
char c1;
scanf("%d",&n);
set<int>s;
while(n){
scanf("%d",&m);
getchar();
c1=getchar();
scanf("%d:%d",&a,&b);
if(m==0){
if(cnt==0)
cout<<"0 0"<<endl;
else{
cout<<cnt<<" ";
printf("%.0f\n",(res1*1.0)/cnt);
}
s.clear();
memset(st,0,sizeof(st));
res1=0;
cnt=0;
n--;
}
else{
if(c1=='S'){
s.insert(m);
st[m]=a*60+b;
}else if(c1=='E'&&s.find(m)!=s.end()){
cnt++;
res1+=a*60+b-st[m];
s.erase(m);
}
}
}
return 0;
}
标签:10,00,纪录,08,阅览室,L1,include,输入 来源: https://blog.csdn.net/abc1235454/article/details/88626009