PAT_A 1041 Be Unique
作者:互联网
PAT_A 1041 Be Unique
分析
建立对应的关系按要求统计分析即可满足题目的要求。
PAT_A 1041 Be Unique
题目的描述
Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,104]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.
Input Specification:
Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤105) and then followed by N bets. The numbers are separated by a space.
Output Specification:
For each test case, print the winning number in a line. If there is no winner, print None
instead.
Sample Input 1:
7 5 31 5 88 67 88 17
Sample Output 1:
31
Sample Input 2:
5 888 666 666 888 888
Sample Output 2:
None
AC的代码
#include<bits/stdc++.h>
using namespace std;
int n, k=0, mp[100005]={0}, nums[100005]={0};
int main(){
cin>>n;
for(int i=0;i<n;i++){
int t;
cin>>t;
mp[t]++;
nums[k++]=t;
}
for(int i=0; i<k; i++){
if(mp[nums[i]]==1){
cout<<nums[i]<<endl;
return 0;
}
}
cout<<"None"<<endl;
return 0;
}
标签:bets,1041,PAT,int,31,Sample,88,Unique 来源: https://www.cnblogs.com/ghosteq/p/16421741.html