1012 数字分类 (20 分)
作者:互联网
给定一系列正整数,请按要求对数字进行分类,并输出以下 5 个数字:
- A1 = 能被 5 整除的数字中所有偶数的和;
- A2 = 将被 5 除后余 1 的数字按给出顺序进行交错求和,即计算 n1−n2+n3−n4⋯;
- A3 = 被 5 除后余 2 的数字的个数;
- A4 = 被 5 除后余 3 的数字的平均数,精确到小数点后 1 位;
- A5 = 被 5 除后余 4 的数字中最大数字。
输入格式:
每个输入包含 1 个测试用例。每个测试用例先给出一个不超过 1000 的正整数 N,随后给出 N 个不超过 1000 的待分类的正整数。数字间以空格分隔。
输出格式:
对给定的 N 个正整数,按题目要求计算 A1~A5 并在一行中顺序输出。数字间以空格分隔,但行末不得有多余空格。
若分类之后某一类不存在数字,则在相应位置输出 N
。
输入样例 1:
13 1 2 3 4 5 6 7 8 9 10 20 16 18
输出样例 1:
30 11 2 9.7 9
输入样例 2:
8 1 2 4 5 6 7 9 16
输出样例 2:
N 11 2 N 9
import java.util.Scanner;
class Main {
public static void main(String[] args) {
boolean b = false;
Scanner scanner = new Scanner(System.in);
int num = scanner.nextInt();
int[] ints = new int[num];
int c = -1;
int a1 = 0, a2 = 0, a3 = 0, a5 = 0, numOfA4 = 0;
double a4 = 0;
for (int i = 0; i < num; i++) {
int temp = scanner.nextInt();
if (temp % 5 == 0 && temp % 2 == 0) {
a1 += temp;
}
if (temp % 5 == 1) {
c *= (-1);
a2 = a2 + c * temp;
b = true;
}
if (temp % 5 == 2) {
a3++;
}
if (temp % 5 == 3) {
a4 += temp;
numOfA4++;
}
if (temp % 5 == 4 && temp > a5) {
a5 = temp;
}
}
if (a1 == 0) {
System.out.printf("N ");
}else {
System.out.print(a1+" ");
}
if (b==false) {
System.out.printf("N ");
}else {
System.out.print(a2+" ");
}
if (a3 == 0) {
System.out.printf("N ");
}else {
System.out.print(a3+" ");
}
if (numOfA4 == 0) {
System.out.printf("N ");
}else {
System.out.printf("%.1f ",a4 /= numOfA4);
}
if (a5 == 0) {
System.out.printf("N");
}else {
System.out.println(a5);
}
}
}
标签:20,数字,temp,int,分类,System,printf,1012,out 来源: https://blog.csdn.net/weixin_53566169/article/details/122638579