pta1020C语言实现
作者:互联网
1020 月饼 (25 分)
月饼是中国人在中秋佳节时吃的一种传统食品,不同地区有许多不同风味的月饼。现给定所有种类月饼的库存量、总售价、以及市场的最大需求量,请你计算可以获得的最大收益是多少。
注意:销售时允许取出一部分库存。样例给出的情形是这样的:假如我们有 3 种月饼,其库存量分别为 18、15、10 万吨,总售价分别为 75、72、45 亿元。如果市场的最大需求量只有 20 万吨,那么我们最大收益策略应该是卖出全部 15 万吨第 2 种月饼、以及 5 万吨第 3 种月饼,获得 72 + 45/2 = 94.5(亿元)。
输入格式:
每个输入包含一个测试用例。每个测试用例先给出一个不超过 1000 的正整数 N 表示月饼的种类数、以及不超过 500(以万吨为单位)的正整数 D 表示市场最大需求量。随后一行给出 N 个正数表示每种月饼的库存量(以万吨为单位);最后一行给出 N 个正数表示每种月饼的总售价(以亿元为单位)。数字间以空格分隔。
输出格式:
对每组测试用例,在一行中输出最大收益,以亿元为单位并精确到小数点后 2 位。
输入样例:
3 20
18 15 10
75 72 45
输出样例:
94.50
这个题目就是很简单的贪心算法,先计算每个月饼的单价,再从单价最高的月饼开始计算即可
但要注意 compare函数最后的return 如果使用的是 - ,则会造成double类型的小数点丢失,所以我这里改成了 >
代码入下:
#include<stdio.h>
#include<stdlib.h>
typedef struct yuebing {
double num;
double price;
double dprice;
}goods;
int compare(const void* p1, const void* p2)
{
struct yuebing* a = (goods*)p1;
struct yuebing* b = (goods*)p2;
return b->dprice > a->dprice;
}
int main()
{
double n, m;
scanf("%lf%lf", &n, &m);
double total = 0;
goods a[1001];
int i = 0;
for (i = 0; i < n; i++)
{
scanf("%lf", &a[i].num);
}
for (i = 0; i < n; i++)
{
scanf("%lf", &a[i].price);
}
for (i = 0; i < n; i++)
{
a[i].dprice = 1.0 * a[i].price / a[i].num;
}
qsort(a, n, sizeof(goods), compare);
i = 0;
while (i < n)
{
if (m < a[i].num)
{
total = total + m * a[i].dprice;
break;
}
else
{
total = total + a[i].price;
m = m - a[i].num;
i++;
}
}
printf("%.2lf", total);
return 0;
}
标签:total,月饼,实现,double,C语言,num,dprice,goods,pta1020 来源: https://blog.csdn.net/m0_53036215/article/details/120470539