其他分享
首页 > 其他分享> > 奇数单增序列

奇数单增序列

作者:互联网

蒜头君给了一个长度为 NN(不大于 500500)的正整数序列(正整数的值不超过 NN),请将其中的所有奇数取出,并按升序输出。

输入格式

共 22 行:

第 11 行为 NN;

第 22 行为 NN 个正整数,其间用空格间隔。

输出格式

增序输出的奇数序列,数据之间以逗号间隔。数据保证至少有一个奇数。

输出时每行末尾的多余空格,不影响答案正确性

样例输入

10
1 3 2 6 5 4 9 8 7 10

样例输出

1,3,5,7,9

 


#include<cstdio>
#include<iostream>
#include<algorithm>
int arr[505];

using namespace std;

int main()
{
    int N;						//	输入数组长度
    int n=0;					//	记录答案数组长度
    scanf("%d",&N);
    
    for(int tmp,i=0; i<N; i++)
    {
        scanf("%d",&tmp);       //   暂存输入的数据
        if(tmp%2)               //  判断是否为奇数
        {
            arr[n++] = tmp;     //  true则放入答案数组
        }
    }
    
    sort(arr,arr+n);            //  调用STL中的sort函数进行从小到大排序
    
    for(int i=0; i<n; i++)
    {
        if(i<n-1)               //  注意输出格式对逗号的要求
        {
            printf("%d,",arr[i]);
        }
        else
        {
            printf("%d",arr[i]);
        }
    }
    return 0;
}

标签:输出,单增,正整数,NN,奇数,int,序列,include
来源: https://www.cnblogs.com/sui-sui/p/15193042.html